Bug 805906 - Error in first-boot when subscription-manager displays message/error dialogs.
Error in first-boot when subscription-manager displays message/error dialogs.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Bryan Kearney
Entitlement Bugs
:
Depends On:
Blocks: 738066
  Show dependency treegraph
 
Reported: 2012-03-22 08:23 EDT by Michael Stead
Modified: 2013-01-10 06:00 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 09:08:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Stead 2012-03-22 08:23:56 EDT
Description of problem:
When subscription manager attempts to show a message/error dialog during registration, the following error occurs:

/usr/share/rhsm/subscription_manager/gui/registergui.py:314: DeprecationWarning: use GtkNotebook.set_current_page
  self.register_notebook.set_page(CREDENTIALS_PAGE)
firstboot ERROR: global name 'ErrorDialog' is not defined
Traceback (most recent call last):
  File "/usr/share/rhsm/subscription_manager/gui/registergui.py", line 294, in _on_registration_finished_cb
    self._finish_registration()
  File "/usr/share/rhn/up2date_client/firstboot/rhsm_login.py", line 239, in _finish_registration
    self._init_sla()
  File "/usr/share/rhn/up2date_client/firstboot/rhsm_login.py", line 287, in _init_sla
    ErrorDialog(_("No service levels will cover all installed products. "
NameError: global name 'ErrorDialog' is not defined
firstboot ERROR: global name 'ErrorDialog' is not defined
Traceback (most recent call last):
  File "/usr/share/rhsm/subscription_manager/gui/registergui.py", line 294, in _on_registration_finished_cb
    self._finish_registration()
  File "/usr/share/rhn/up2date_client/firstboot/rhsm_login.py", line 239, in _finish_registration
    self._init_sla()
  File "/usr/share/rhn/up2date_client/firstboot/rhsm_login.py", line 287, in _init_sla
    ErrorDialog(_("No service levels will cover all installed products. "
NameError: global name 'ErrorDialog' is not defined

This seems to put the first-boot process in a weird state.


NOTE: This also happens with OkDilogs as well.


Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. On RHEL6.3 system, ensure system is not registered and has an installed product that does not have any entitlements. I used 69.pem (standard with install) and a CP server with only test data (nothing that would satisfy 69.pem)

2. launch firstboot

3. follow steps through subscription-manager registration

4. After org selection screen, sub-man will attempt to show a message dialog stating "No service levels will cover all installed products...." but will fail.
  
Actual results:
An actual error dialog is displayed showing failure.

Expected results:
User should see the message dialog stating that of step 4.
Comment 1 James Bowes 2012-03-22 08:30:26 EDT
fixed in commit bb2deaf074e, should be in subscription-manager-0.99.11
Comment 4 J.C. Molet 2012-04-05 14:00:53 EDT
subscription-manager-gnome-0.99.12-1.git.18.188dde8.el6.x86_64
subscription-manager-0.99.12-1.git.18.188dde8.el6.x86_64
subscription-manager-firstboot-0.99.12-1.git.18.188dde8.el6.x86_64
python-rhsm-0.99.7-1.git.1.e68bc91.el6.noarch


Testing with incorrect user/pass in firstboot:

firstboot ERROR: certificate verify failed
None

^^^^^^^^ NO TRACEBACK SHOWN


Testing with certificate failure:

firstboot ERROR: certificate verify failed
None


^^^^^^^^ NO TRACEBACKS FOUND

The no service levels error does not print anything to the console but the error dialog displays as expected.


Testing with a bad proxy:

firstboot ERROR: [Errno -2] Name or service not known
None

^^^^^^^^ NO TRACEBACKS FOUND

All of these errors do not cause tracebacks, and the error dialogs all show as expected.  Marking VERIFIED.
Comment 6 errata-xmlrpc 2012-06-20 09:08:13 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0804.html

Note You need to log in before you can comment on or make changes to this bug.