Bug 805909 - pagination should handle deployment deletion
pagination should handle deployment deletion
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.0.0
Unspecified Unspecified
unspecified Severity medium
: 1.0.2
: ---
Assigned To: Imre Farkas
wes hayutin
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-22 08:44 EDT by Imre Farkas
Modified: 2012-12-04 10:00 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
When deleting applications from the last page caused the page to reload with a message: "no matching results found" This bug updates pagination. After application deletion, the previous page reloads.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 10:00:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
page 3 with page 2 deployments (143.81 KB, image/png)
2012-09-20 18:16 EDT, Ronelle Landy
no flags Details

  None (edit)
Description Imre Farkas 2012-03-22 08:44:00 EDT
Description of problem:
When you have pagination rendered on the deployments tab of the table view of monitor page and delete all the deployments from the last page of pagination, the page reloads with no matching result found message.

Steps to Reproduce:
1. Create 20 deployments
2. Go to Monitor -> Table view -> Deployments -> 2nd page
3. Delete all deployments on this page
  
Actual results:
You get No matching results message when the page reloads

Expected results:
The pagination should go back to the previous page
Comment 1 Imre Farkas 2012-03-25 10:17:13 EDT
Patch has been posted: https://fedorahosted.org/pipermail/aeolus-devel/2012-March/009676.html
Comment 2 Imre Farkas 2012-03-28 05:25:17 EDT
A rebased version: https://fedorahosted.org/pipermail/aeolus-devel/2012-March/009710.html
Comment 3 Imre Farkas 2012-04-13 07:40:32 EDT
Another revision has been sent to the list:
https://fedorahosted.org/pipermail/aeolus-devel/2012-April/009988.html
Comment 4 Imre Farkas 2012-04-23 05:40:03 EDT
This issue has been fixed. Please verify the commit 456078f6a23200c8cbf383b102b57309b5d053b7
Comment 6 Ronelle Landy 2012-09-20 18:15:26 EDT
Tested rpms:

>> rpm -qa |grep aeolus
aeolus-configure-2.8.6-1.el6cf.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
rubygem-aeolus-cli-0.7.1-1.el6cf.noarch
aeolus-conductor-0.13.8-1.el6cf.noarch
aeolus-conductor-daemons-0.13.8-1.el6cf.noarch
aeolus-conductor-doc-0.13.8-1.el6cf.noarch
aeolus-all-0.13.8-1.el6cf.noarch

 - Had 39 deployments available which ran to 3 pages (with pagination)
 - Deleted the last two deployments which were visible on page 3
 - Conductor showed page two when returning from the delete operation 

See the attached screenshot - showing page 3 in the URL but with the deployments of page 2. No error is returned.

Marking this BZ as 'verified'.
Comment 7 Ronelle Landy 2012-09-20 18:16:00 EDT
Created attachment 615157 [details]
page 3 with page 2 deployments
Comment 9 errata-xmlrpc 2012-12-04 10:00:40 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.