Bug 805971 - [RFE] Let me specify --org and --env when creating a new user
[RFE] Let me specify --org and --env when creating a new user
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Hammer (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity low (vote)
: Unspecified
: --
Assigned To: Mike McCune
sthirugn@redhat.com
: FutureFeature, Triaged
: 808331 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-22 11:22 EDT by Og Maciel
Modified: 2014-09-11 08:25 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-09-11 08:25:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Og Maciel 2012-03-22 11:22:40 EDT
Description of problem:

Currently there is no obvious way to specify a Org or Env for a user with katello user command. It would be useful to have the option to specify these values during creation or update.

# katello  user --help
Usage: katello <options> user <action> <options>
Supported Actions:
	create         create user
	info           list information about user
	list           list all known users
	update         update an user
	delete         delete user
	report         user report
	assign_role    assign role to a user
	unassign_role  unassign role to a user
	list_roles     list user's roles

Options:
  -h, --help  show this help message and exit

# katello user create --help
Usage: katello [options]

Options:
  -h, --help           show this help message and exit
  -g                   grep friendly output
  -v                   verbose, more structured output
  -d DELIMITER         grep friendly output column delimiter
  --username=USERNAME  user name (required)
  --password=PASSWORD  initial password (required)
  --email=EMAIL        email (required)
  --disabled=DISABLED  disabled account (default is 'false')

# katello update --help
Usage: katello [options]

Options:
  -h, --help           show this help message and exit
  -g                   grep friendly output
  -v                   verbose, more structured output
  -d DELIMITER         grep friendly output column delimiter
  --username=USERNAME  user name (required)
  --password=PASSWORD  initial password
  --email=EMAIL        email
  --disabled=DISABLED  disabled account (default is 'false')

Version-Release number of selected component (if applicable):

Name        : katello-cli
Arch        : noarch
Version     : 0.1.105
Release     : 1.el6
Size        : 32 k
Repo        : installed
From repo   : system-engine
Summary     : Client package for managing application life-cycle for Linux systems
URL         : http://www.katello.org
License     : GPLv2
Description : Provides a client package for managing application life-cycle
            : for Linux systems

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Og Maciel 2012-03-30 07:10:53 EDT
*** Bug 808331 has been marked as a duplicate of this bug. ***
Comment 2 Bryan Kearney 2014-03-26 16:39:51 EDT
Not at creation time, but you can run

"organization add-user --name %s --user-id %s"

in hammer. ENV is no longer relevant
Comment 4 sthirugn@redhat.com 2014-09-03 10:57:36 EDT
Verified.

Note: cli now uses hammer and we provide only the following associations:

# hammer -u admin -p changeme user create --help
Usage:
    hammer user create [OPTIONS]

Options:
    --admin ADMIN                 Is an admin account?
    --auth-source-id AUTH_SOURCE_ID  
    --default-location-id DEFAULT_LOCATION_ID  
    --default-organization-id DEFAULT_ORGANIZATION_ID  
    --firstname FIRSTNAME          
    --lastname LASTNAME            
    --login LOGIN                  
    --mail MAIL                    
    --password PASSWORD            
    -h, --help                    print help

# hammer -u admin -p changeme user update --help
Usage:
    hammer user update [OPTIONS]

Options:
    --admin ADMIN                 Is an admin account?
    --auth-source-id AUTH_SOURCE_ID  
    --default-location-id DEFAULT_LOCATION_ID  
    --default-organization-id DEFAULT_ORGANIZATION_ID  
    --firstname FIRSTNAME          
    --id ID                        
    --lastname LASTNAME            
    --login LOGIN                 User's login to search by
    --mail MAIL                    
    --new-login NEW_LOGIN          
    --password PASSWORD            
    -h, --help                    print help

# hammer -u admin -p changeme user --help
Usage:
    hammer user [OPTIONS] SUBCOMMAND [ARG] ...

Parameters:
    SUBCOMMAND                    subcommand
    [ARG] ...                     subcommand arguments

Subcommands:
    add-role                      Assign a user role
    create                        Create an user.
    delete                        Delete an user.
    info                          Show an user.
    list                          List all users.
    remove-role                   Remove a user role
    update                        Update an user.

Options:
    -h, --help                    print help

Version Tested:
GA Snap 7 - Satellite-6.0.4-RHEL-6-20140829.0

* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.9.23-1.el6_5.noarch
* candlepin-common-1.0.1-1.el6_5.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.9.23-1.el6_5.noarch
* candlepin-tomcat6-0.9.23-1.el6_5.noarch
* elasticsearch-0.90.10-6.el6sat.noarch
* foreman-1.6.0.42-1.el6sat.noarch
* foreman-compute-1.6.0.42-1.el6sat.noarch
* foreman-gce-1.6.0.42-1.el6sat.noarch
* foreman-libvirt-1.6.0.42-1.el6sat.noarch
* foreman-ovirt-1.6.0.42-1.el6sat.noarch
* foreman-postgresql-1.6.0.42-1.el6sat.noarch
* foreman-proxy-1.6.0.30-1.el6sat.noarch
* foreman-selinux-1.6.0.14-1.el6sat.noarch
* foreman-vmware-1.6.0.42-1.el6sat.noarch
* katello-1.5.0-30.el6sat.noarch
* katello-ca-1.0-1.noarch
* katello-certs-tools-1.5.6-1.el6sat.noarch
* katello-installer-0.0.62-1.el6sat.noarch
* openldap-2.4.23-34.el6_5.1.x86_64
* openldap-devel-2.4.23-34.el6_5.1.x86_64
* pulp-katello-0.3-4.el6sat.noarch
* pulp-nodes-common-2.4.1-0.5.rc1.el6sat.noarch
* pulp-nodes-parent-2.4.1-0.5.rc1.el6sat.noarch
* pulp-puppet-plugins-2.4.1-0.5.rc1.el6sat.noarch
* pulp-puppet-tools-2.4.1-0.5.rc1.el6sat.noarch
* pulp-rpm-plugins-2.4.1-0.5.rc1.el6sat.noarch
* pulp-selinux-2.4.1-0.5.rc1.el6sat.noarch
* pulp-server-2.4.1-0.5.rc1.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
* ruby193-rubygem-runcible-1.1.0-2.el6sat.noarch
Comment 5 Bryan Kearney 2014-09-11 08:25:58 EDT
This was delivered with Satellite 6.0 which was released on 10 September 2014.

Note You need to log in before you can comment on or make changes to this bug.