Bug 806012 - Proxy Error when mass-updating lots of bugs.
Proxy Error when mass-updating lots of bugs.
Status: CLOSED CANTFIX
Product: Bugzilla
Classification: Community
Component: Creating/Changing Bugs (Show other bugs)
4.2
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: ---
Assigned To: PnT DevOps Devs
tools-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-22 12:52 EDT by Dave Jones
Modified: 2015-01-04 17:31 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-09 01:52:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Jones 2012-03-22 12:52:18 EDT
I'm trying to do a 'change multiple bugs at once' for a lot of bugs (around 500).
When I click submit I get ..

Proxy Error

The proxy server received an invalid response from an upstream server.
The proxy server could not handle the request POST /process_bug.cgi.

Reason: Error reading from remote server

Apache Server at bugzilla.redhat.com Port 443
Comment 1 Dave Jones 2012-07-12 11:48:21 EDT
I just got this again after trying to batch close 36 bugs.

Not sure if it makes a difference, but this is over the vpn.
Comment 2 Jan Stodola 2012-08-01 08:48:46 EDT
I'm getting following proxy error when using the bugzilla command line tool to list bugs:

jstodola@jstodola ~$ bugzilla query --flag=rhel-6.3.0+ --ids

Invalid server response: 502 Proxy Error
jstodola@jstodola ~$

I was told this is caused by this bug, so I'm adding the reproducer here.
Comment 3 Simon Green 2012-10-09 01:52:19 EDT
Unfortunately the proxy server in front of the production Bugzilla web servers has a two minute time out. When updating lots of bugs (i.e. when it takes longer than this), you will receive this message.

The transaction still continues in the background until successful competition.

Note You need to log in before you can comment on or make changes to this bug.