Bug 806111 - RAID1 down conversion with 1st leg device specified fails
RAID1 down conversion with 1st leg device specified fails
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: lvm2 (Show other bugs)
6.3
x86_64 Linux
high Severity high
: rc
: ---
Assigned To: Jonathan Earl Brassow
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-22 18:23 EDT by Corey Marthaler
Modified: 2012-06-20 11:03 EDT (History)
10 users (show)

See Also:
Fixed In Version: lvm2-2.02.95-4.el6
Doc Type: Bug Fix
Doc Text:
New feature in rhel6.3. No release notes necessary.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 11:03:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corey Marthaler 2012-03-22 18:23:18 EDT
Description of problem:
This is basically bug 801967, but not it fail with the 1st device as well.

 [root@taft-01 ~]# lvcreate --type raid1 -m 2 -L 700M -n lv taft
  Logical volume "lv" created

[root@taft-01 ~]# lvs -a -o +devices
 LV            VG     Attr     LSize   Copy%  Devices
 lv            taft   rwi-a-m- 700.00m 100.00 lv_rimage_0(0),lv_rimage_1(0),lv_rimage_2(0)
 [lv_rimage_0] taft   iwi-aor- 700.00m        /dev/sdb1(1)
 [lv_rimage_1] taft   iwi-aor- 700.00m        /dev/sdb2(1)
 [lv_rimage_2] taft   iwi-aor- 700.00m        /dev/sdc1(1)
 [lv_rmeta_0]  taft   ewi-aor-   4.00m        /dev/sdb1(0)
 [lv_rmeta_1]  taft   ewi-aor-   4.00m        /dev/sdb2(0)
 [lv_rmeta_2]  taft   ewi-aor-   4.00m        /dev/sdc1(0)

[root@taft-01 ~]# lvconvert -m 1 taft/lv /dev/sdb1
  device-mapper: rename ioctl on taft-lv_rimage_2 failed: Device or resource busy
  Failed to rename taft-lv_rimage_2 (253:7) to taft-lv_rimage_1
  Failed to resume taft/lv after committing changes
  libdevmapper exiting with 5 device(s) still suspended.

# LVM THEN HANGS


Mar 22 17:14:57 taft-01 lvm[1274]: No longer monitoring RAID device taft-lv for events.
Mar 22 17:14:57 taft-01 kernel: device-mapper: ioctl: Unable to change name on mapped device taft-lv_rimage_2 to one that already exists: taft-lv_rimage_1
Mar 22 17:18:04 taft-01 kernel: INFO: task lvconvert:2425 blocked for more than 120 seconds.
Mar 22 17:18:04 taft-01 kernel: "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
Mar 22 17:18:04 taft-01 kernel: lvconvert     D 0000000000000001     0  2425   2051 0x00000080
Mar 22 17:18:04 taft-01 kernel: ffff880216dd9b18 0000000000000086 ffff880216dd9ad8 ffffffffa000422e
Mar 22 17:18:04 taft-01 kernel: ffff880216dd9ae8 00000000dc28a22f ffff880216dd9b08 ffff880216306c80
Mar 22 17:18:04 taft-01 kernel: ffff880217be3ab8 ffff880216dd9fd8 000000000000fb48 ffff880217be3ab8
Mar 22 17:18:04 taft-01 kernel: Call Trace:
Mar 22 17:18:04 taft-01 kernel: [<ffffffffa000422e>] ? dm_table_unplug_all+0x8e/0x100 [dm_mod]
Mar 22 17:18:04 taft-01 kernel: [<ffffffff8109b5d9>] ? ktime_get_ts+0xa9/0xe0
Mar 22 17:18:04 taft-01 kernel: [<ffffffff814f81b3>] io_schedule+0x73/0xc0
Mar 22 17:18:04 taft-01 kernel: [<ffffffff811b473e>] __blockdev_direct_IO_newtrunc+0x6fe/0xb90
Mar 22 17:18:04 taft-01 kernel: [<ffffffff8125b7bd>] ? get_disk+0x7d/0xf0
[...]


Version-Release number of selected component (if applicable):
2.6.32-220.4.2.el6.x86_64

lvm2-2.02.95-2.el6    BUILT: Fri Mar 16 08:39:54 CDT 2012
lvm2-libs-2.02.95-2.el6    BUILT: Fri Mar 16 08:39:54 CDT 2012
lvm2-cluster-2.02.95-2.el6    BUILT: Fri Mar 16 08:39:54 CDT 2012
udev-147-2.40.el6    BUILT: Fri Sep 23 07:51:13 CDT 2011
device-mapper-1.02.74-2.el6    BUILT: Fri Mar 16 08:39:54 CDT 2012
device-mapper-libs-1.02.74-2.el6    BUILT: Fri Mar 16 08:39:54 CDT 2012
device-mapper-event-1.02.74-2.el6    BUILT: Fri Mar 16 08:39:54 CDT 2012
device-mapper-event-libs-1.02.74-2.el6    BUILT: Fri Mar 16 08:39:54 CDT 2012
cmirror-2.02.95-2.el6    BUILT: Fri Mar 16 08:39:54 CDT 2012
Comment 1 Jonathan Earl Brassow 2012-04-10 21:25:29 EDT
This bug is more general than that...  You will run into problems if you specify anything other than the last 2 positions of the array.
Comment 3 Jonathan Earl Brassow 2012-04-10 22:02:46 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
New feature in rhel6.3.  No release notes necessary.
Comment 6 Corey Marthaler 2012-04-11 12:11:07 EDT
Fix verified in the latest rpms.


2.6.32-251.el6.x86_64
lvm2-2.02.95-4.el6    BUILT: Wed Apr 11 09:03:19 CDT 2012
lvm2-libs-2.02.95-4.el6    BUILT: Wed Apr 11 09:03:19 CDT 2012
lvm2-cluster-2.02.95-4.el6    BUILT: Wed Apr 11 09:03:19 CDT 2012
udev-147-2.40.el6    BUILT: Fri Sep 23 07:51:13 CDT 2011
device-mapper-1.02.74-4.el6    BUILT: Wed Apr 11 09:03:19 CDT 2012
device-mapper-libs-1.02.74-4.el6    BUILT: Wed Apr 11 09:03:19 CDT 2012
device-mapper-event-1.02.74-4.el6    BUILT: Wed Apr 11 09:03:19 CDT 2012
device-mapper-event-libs-1.02.74-4.el6    BUILT: Wed Apr 11 09:03:19 CDT 2012
cmirror-2.02.95-4.el6    BUILT: Wed Apr 11 09:03:19 CDT 2012


[root@taft-01 ~]# lvcreate --type raid1 -m 2 -L 700M -n lv taft
  Logical volume "lv" created

[root@taft-01 ~]# lvs -a -o +devices
  LV            VG    Attr     LSize   Log Copy%  Devices
  lv            taft  rwi-a-m- 700.00m     100.00 lv_rimage_0(0),lv_rimage_1(0),lv_rimage_2(0)
  [lv_rimage_0] taft  iwi-aor- 700.00m            /dev/sdb1(1)
  [lv_rimage_1] taft  iwi-aor- 700.00m            /dev/sdc1(1)
  [lv_rimage_2] taft  iwi-aor- 700.00m            /dev/sdd1(1)
  [lv_rmeta_0]  taft  ewi-aor-   4.00m            /dev/sdb1(0)
  [lv_rmeta_1]  taft  ewi-aor-   4.00m            /dev/sdc1(0)
  [lv_rmeta_2]  taft  ewi-aor-   4.00m            /dev/sdd1(0)

[root@taft-01 ~]# lvconvert -m 1 taft/lv /dev/sdb1

[root@taft-01 ~]# lvs -a -o +devices
  LV            VG    Attr     LSize   Log Copy%  Devices
  lv            taft  rwi-a-m- 700.00m     100.00 lv_rimage_0(0),lv_rimage_1(0)
  [lv_rimage_0] taft  iwi-aor- 700.00m            /dev/sdc1(1)
  [lv_rimage_1] taft  iwi-aor- 700.00m            /dev/sdd1(1)
  [lv_rmeta_0]  taft  ewi-aor-   4.00m            /dev/sdc1(0)
  [lv_rmeta_1]  taft  ewi-aor-   4.00m            /dev/sdd1(0)
Comment 7 errata-xmlrpc 2012-06-20 11:03:05 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0962.html

Note You need to log in before you can comment on or make changes to this bug.