Bug 806112 - RTL8111/8168B Ethernet NIC Stopped working with kernel update
RTL8111/8168B Ethernet NIC Stopped working with kernel update
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
Unspecified Linux
unspecified Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-22 18:24 EDT by Rich
Modified: 2012-03-26 21:48 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-26 21:48:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rich 2012-03-22 18:24:17 EDT
Description of problem:
After updating to kernel-3.2.10-3.fc16.x86_64 NetworkManager failed to find a network interface. ifconfig failed to find a device. I found the following in my 'messages' log:

Mar 22 05:29:45 frodo kernel: [   34.521035] r8169 Gigabit Ethernet driver 2.3LK-NAPI loaded
Mar 22 05:29:45 frodo kernel: [   34.521071] r8169 0000:02:00.0: (unregistered net_device): Mem-Wr-Inval unavailable
Mar 22 05:29:45 frodo kernel: [   34.521076] r8169 0000:02:00.0: (unregistered net_device): region #2 not an MMIO resource, aborting

Version-Release number of selected component (if applicable):

kernel-3.2.10-3.fc16.x86_64

The bug is still present as of kernel-3.3.0-4.fc16.

Reverting to kernel-3.1.0-7.fc16.x86_64 fixes it.

How reproducible:
On a system with the affected hardware (RTL8111/8168B Gigabit Ethernet NIC), upgrade to kernel 3.2.10-3.fc16.x86_64 or kernel-3.3.0-4.fc16.

Steps to Reproduce:
1. sudo yum update
2. reboot
3. curse
  
Actual results:
No networking capability

Expected results:
Network works

Additional info:
Comment 1 Rich 2012-03-26 21:48:45 EDT
I am retracting this bug report because 1) i cannot reproduce it with kernel-3.3  and 2) because I reproduced the bug with kernel-3.1. I suspect I have an intermittent hardware glitch. Although it still could be a software timing bug (e.g. a race condition), I am no longer sure...

Rich

Note You need to log in before you can comment on or make changes to this bug.