Bug 806177 - Concurrent migration will cause virsh command hang
Concurrent migration will cause virsh command hang
Status: CLOSED DUPLICATE of bug 803186
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt (Show other bugs)
6.3
x86_64 Linux
high Severity high
: rc
: ---
Assigned To: Jiri Denemark
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-23 01:57 EDT by weizhang
Modified: 2012-03-27 22:28 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-27 07:57:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
libvirtd.log (468.20 KB, text/plain)
2012-03-23 01:58 EDT, weizhang
no flags Details
backtrace (13.12 KB, text/plain)
2012-03-23 01:59 EDT, weizhang
no flags Details

  None (edit)
Description weizhang 2012-03-23 01:57:35 EDT
Description of problem:
Concurrent migration will hang on  libvirt-0.9.10-6.el6.x86_64.rpm

Version-Release number of selected component (if applicable):
kernel-2.6.32-250.el6.x86_64
qemu-kvm-0.12.1.2-2.262.el6.x86_64
libvirt-0.9.10-6.el6.x86_64

How reproducible:
90%

Steps to Reproduce:
1. Start 15 guests with empty disk
2. Do migration with
# for i in {1..15}; do virsh migrate --live mig-$i qemu+ssh://{target ip}/system --unsafe & sleep 1; done
3. Do virsh list
  
Actual results:
virsh list will hang, and migration will not finished

Expected results:
virsh will not hang, migration succeed without error

Additional info:
Comment 1 weizhang 2012-03-23 01:58:30 EDT
Created attachment 572163 [details]
libvirtd.log
Comment 2 weizhang 2012-03-23 01:59:13 EDT
Created attachment 572164 [details]
backtrace
Comment 3 Jiri Denemark 2012-03-23 06:16:36 EDT
How is this different from bug 803186, is the only difference in removing virsh migrate-setmaxdowntime command from the loop?

This is very likely a dup of that bug but I'll wait for the additional info before closing it.
Comment 4 weizhang 2012-03-25 22:18:59 EDT
I report it because the bug 803186 is reported on rhel 6.2 but I can only reproduce this bug on rhel6.3, and on rhel6.2 concurrent migration will not cause virsh command hang
Comment 5 Jiri Denemark 2012-03-27 07:57:15 EDT
It's a race so you were not probably lucky enough to hit it on rhel6.2. I wasn't able to reproduce this bug even on rhel6.3 (until I saw the backtrace and logs).

*** This bug has been marked as a duplicate of bug 803186 ***
Comment 6 weizhang 2012-03-27 22:28:12 EDT
Please have a look at bug 803186 comment 17

Note You need to log in before you can comment on or make changes to this bug.