Bug 806220 - list of permissive domains is not empty after disabling permissivedomains module
list of permissive domains is not empty after disabling permissivedomains module
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: selinux-policy (Show other bugs)
6.3
All Linux
unspecified Severity unspecified
: rc
: ---
Assigned To: Miroslav Grepl
Milos Malik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-23 05:05 EDT by Milos Malik
Modified: 2012-06-20 08:32 EDT (History)
1 user (show)

See Also:
Fixed In Version: selinux-policy-3.7.19-144.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1036188 (view as bug list)
Environment:
Last Closed: 2012-06-20 08:32:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milos Malik 2012-03-23 05:05:25 EDT
Description of problem:

Version-Release number of selected component (if applicable):
selinux-policy-targeted-3.7.19-142.el6.noarch
selinux-policy-minimum-3.7.19-142.el6.noarch
selinux-policy-3.7.19-142.el6.noarch
selinux-policy-doc-3.7.19-142.el6.noarch
selinux-policy-mls-3.7.19-142.el6.noarch

How reproducible:
always

Steps to Reproduce:
# sestatus 
SELinux status:                 enabled
SELinuxfs mount:                /selinux
Current mode:                   enforcing
Mode from config file:          enforcing
Policy version:                 24
Policy from config file:        targeted
# semodule -d permissivedomains
# semodule -l | grep permissivedomains
permissivedomains	1.0.0	Disabled
# semanage permissive -l 

Builtin Permissive Types 

deltacloudd_t
mongod_t
iwhd_t
thin_t
#
  
Actual results:
* the list is not empty

Expected results:
* the list is empty
Comment 1 Miroslav Grepl 2012-03-23 05:13:29 EDT
Yes, there was a bug which I fixed. Easy fix.
Comment 2 Miroslav Grepl 2012-04-03 14:36:52 EDT
Fixed in selinux-policy-3.7.19-144.el6
Comment 5 Daniel Walsh 2012-05-02 15:53:59 EDT
Is that something we ship?  Disabling the permissivedomains here will only disable the ones that we ship.  If a user creates a permissive domain or adds one using 

semanage permissive -a bcfg2_t

Then disabling the permissivedomain.pp  file will have no effect.
Comment 6 Miroslav Grepl 2012-05-03 02:44:56 EDT
We don't ship this policy in RHEL6.3.
Comment 8 errata-xmlrpc 2012-06-20 08:32:29 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0780.html

Note You need to log in before you can comment on or make changes to this bug.