Bug 806226 - virt-who dead but pid file exists
virt-who dead but pid file exists
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-who (Show other bugs)
5.9
Unspecified Unspecified
medium Severity medium
: alpha
: ---
Assigned To: Radek Novacek
Entitlement Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-23 05:14 EDT by Hui Wang
Modified: 2016-11-30 19:30 EST (History)
3 users (show)

See Also:
Fixed In Version: virt-who-0.7-1.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-08 02:35:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hui Wang 2012-03-23 05:14:28 EDT
Description of problem:
There are two machine, machine1 and machine2.
Run "ssh root@$remote_machine1_ip "service virt-who restart"" on machine2, check the virt-who service status on machine1, it will report "virt-who dead but pid file exists". 

Version-Release number of selected component (if applicable):
virt-who-0.5-5.el5
subscription-manager-0.98.14-1.el5

How reproducible:
always

Steps to Reproduce:
1. Run "ssh root@$remote_machine1_ip "service virt-who restart"" on machine2
2. Check the virt-who service status on machine1
  
Actual results:
virt-who dead but pid file exists

Expected results:
virt-who is running

Additional info:
Comment 2 RHEL Product and Program Management 2012-04-02 09:10:24 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 3 Radek Novacek 2012-07-17 04:07:43 EDT
This bug has been fixed in virt-who-0.7-1.el5.
Comment 5 Hui Wang 2012-08-29 04:11:28 EDT
Moving to verified.

version:
virt-who-0.7-4.el5
subscription-manager-firstboot-1.0.13-1.el5
subscription-manager-1.0.13-1.el5
subscription-manager-gui-1.0.13-1.el5
python-rhsm-1.0.5-1.el5
katello-headpin-all-0.2.13-1.el6_2.noarch
candlepin-0.6.5-1.el6_2.noarch

Step:
1. Run "ssh root@$remote_machine1_ip "service virt-who restart"" on machine2

# ssh 10.66.13.64 "service virt-who restart"
root@10.66.13.64's password: 
Stopping virt-who: [  OK  ]
Starting virt-who: [  OK  ]
[root@localhost wanghui]# 

2. Check the virt-who service status on machine1
# service virt-who status
virt-who (pid  434) is running...
Comment 7 errata-xmlrpc 2013-01-08 02:35:34 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0072.html

Note You need to log in before you can comment on or make changes to this bug.