Bug 806260 - Can't git push a scale application successfully
Can't git push a scale application successfully
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Pod (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Rob Millner
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-23 06:59 EDT by bzhao
Modified: 2015-05-14 21:49 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-13 14:32:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
developmentLog (923.47 KB, text/x-log)
2012-03-23 07:11 EDT, bzhao
no flags Details
output log for git push a scalable app using REST API (6.28 KB, text/x-log)
2012-03-27 03:40 EDT, bzhao
no flags Details

  None (edit)
Description bzhao 2012-03-23 06:59:52 EDT
Description of problem:
It'll output error message " " after git push the scale application

Version-Release number of selected component (if applicable):
rhc-0.89.2-1.git.9.6a2dab6.el6.noarch

How reproducible:
Always

Steps to Reproduce:
1.Create an scalable app using REST API
# curl -k -H "Accept: application/xml" --user "bzhao:xx"  https://ec2-23-20-181-144.compute-1.amazonaws.com/broker/rest/domains/bzhao/applications -X POST -d name=nodescale -d cartridge=nodejs-0.6 -d scale=true

  
Actual results:
It'll output error message "The remote end hung up unexpectedly" after git push

Expected results:
git push successfully without any error

Additional info:
# git push
...................
Delta compression using up to 4 threads.
Compressing objects: 100% (2/2), done.
Writing objects: 100% (3/3), 277 bytes, done.
Total 3 (delta 1), reused 0 (delta 0)
remote: Stopping application...
remote: Done
remote: ~/git/bd64e56175.git ~/git/bd64e56175.git
remote: ~/git/bd64e56175.git
remote: Running .openshift/action_hooks/pre_build
remote: Running .openshift/action_hooks/build
remote: fatal: 'all-gears' does not appear to be a git repository
remote: fatal: The remote end hung up unexpectedly
remote: fatal: 'all-gears' does not appear to be a git repository
remote: fatal: The remote end hung up unexpectedly
remote: Running .openshift/action_hooks/deploy
remote: Starting application...
remote: Done
Comment 1 bzhao 2012-03-23 07:11:48 EDT
Created attachment 572244 [details]
developmentLog
Comment 2 bzhao 2012-03-27 03:40:42 EDT
Created attachment 572958 [details]
output log for git push a scalable app using REST API
Comment 3 bzhao 2012-03-27 04:16:22 EDT
Git push successfully and the scalable app could be accessed normally, but there is error in output..
error message as follows:
Could not create directory '/var/lib/stickshift/888fd01bff914ab58e67d1febb0e4a46/.ssh'

Please see output log i uploaded for detailed information
Comment 4 Xiaoli Tian 2012-03-27 04:23:59 EDT
Lower the priority since there's only some error log .
Comment 5 Rob Millner 2012-03-27 18:18:58 EDT
Commit 32c0e2e makes ssh not report the error message.

Verified I can git push my scalable nodejs application.
Comment 6 bzhao 2012-03-28 07:25:36 EDT
Passed verifition on devenv_1674

Note You need to log in before you can comment on or make changes to this bug.