Bug 806305 - BRMS 5.3 needs to use hibernate product version in EAP 5.1.2
BRMS 5.3 needs to use hibernate product version in EAP 5.1.2
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise BRMS Platform 5
Classification: JBoss
Component: Build Process (Show other bugs)
BRMS 5.3.0.GA
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Ryan Zhang
Lukáš Petrovický
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-23 08:05 EDT by Ryan Zhang
Modified: 2013-02-20 03:20 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-20 03:20:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ryan Zhang 2012-03-23 08:05:37 EDT
Description of problem:
We should makethe hibernate versions used in BRMS 5.3 as the same as the ones used in EAP 5.1.2.

I listed all the hibernate componets in brms standalone package(ER5). It looks like:

[rzhang@localhost default]$ find . -name "hibernate*.jar"
./deploy/jboss-brms.war/WEB-INF/lib/hibernate-commons-annotations-3.1.0.GA.jar
./deploy/jboss-brms.war/WEB-INF/lib/hibernate-core-3.3.2.GA.jar
./deploy/jboss-brms.war/WEB-INF/lib/hibernate-validator-3.1.0.GA.jar
./deploy/jbpm-console.war/WEB-INF/lib/hibernate-entitymanager-3.4.0.GA.jar
./deploy/jbpm-console.war/WEB-INF/lib/hibernate-annotations-3.4.0.GA.jar
./deploy/jbpm-console.war/WEB-INF/lib/hibernate-commons-annotations-3.1.0.GA.jar
./deploy/jbpm-console.war/WEB-INF/lib/hibernate-tools-3.2.3.GA.jar
./deploy/jbpm-console.war/WEB-INF/lib/hibernate-core-3.3.2.GA.jar
./deploy/designer.war/WEB-INF/lib/hibernate-entitymanager-3.4.0.GA.jar
./deploy/designer.war/WEB-INF/lib/hibernate-annotations-3.4.0.GA.jar
./deploy/designer.war/WEB-INF/lib/hibernate-commons-annotations-3.1.0.GA.jar
./deploy/designer.war/WEB-INF/lib/hibernate-core-3.3.2.GA.jar

There are only serval minor versions need to upgrade. This should be compatiable and no impact to the function.

hibernate-core-3.3.2.GA.jar should upgrade to 3.3.2.GA_CP04
hibernate-entitymanager-3.4.0.GA.jar should upgrade to 3.4.0.GA_CP04
hibernate-annotations-3.4.0.GA.jar should upgrade to 3.4.0.GA_CP04

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Ryan Zhang 2012-03-29 03:50:26 EDT
NVR: hibernate3-3.3.2-1.8.GA_CP04.ep5.el6 has been taged under soa-brms-5.2 
Need to update the upsteam code in drools parent pom.xml
Comment 3 Marco Rietveld 2012-09-03 10:13:33 EDT
This has been fixed with the new ee6/eap6 specific wars (or at least, this has been fixed for console and human-task, not for guvnor that I know of.. ).
Comment 4 Lukáš Petrovický 2013-02-20 03:20:02 EST
This has been fixed and we now support both EAP5 and EAP6's respective Hibernate versions.

Note You need to log in before you can comment on or make changes to this bug.