Bug 806345 - can't boot from the harddisk after the installation
can't boot from the harddisk after the installation
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-23 09:56 EDT by Karel Volný
Modified: 2013-05-07 19:11 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-07 19:11:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda logs (133.13 KB, application/x-compressed-tar)
2012-03-23 11:34 EDT, Karel Volný
no flags Details
anaconda.ifcfg.log (5.46 KB, text/x-log)
2012-03-29 06:44 EDT, Karel Volný
no flags Details
anaconda.log (29.70 KB, text/x-log)
2012-03-29 06:45 EDT, Karel Volný
no flags Details
anaconda.program.log (206.30 KB, text/x-log)
2012-03-29 06:45 EDT, Karel Volný
no flags Details
anaconda.storage.log (349.48 KB, text/x-log)
2012-03-29 06:45 EDT, Karel Volný
no flags Details
anaconda.syslog (97.09 KB, text/plain)
2012-03-29 06:46 EDT, Karel Volný
no flags Details
anaconda.xlog (25.39 KB, text/plain)
2012-03-29 06:46 EDT, Karel Volný
no flags Details
anaconda.yum.log (251.04 KB, text/x-log)
2012-03-29 06:47 EDT, Karel Volný
no flags Details

  None (edit)
Description Karel Volný 2012-03-23 09:56:22 EDT
Description of problem:
I've tried to install F17 Alpha. After a few hours of copying packages, I'm stuck with unbootable harddisk and it seems I'll have to repartition and reinstall again, waiting another few hours, just because some wise head thinks that using by default GPT is the greatest idea since peanut butter.

Version-Release number of selected component (if applicable):
F17 Alpha DVD x86_64

How reproducible:
haven't tried

Steps to Reproduce:
1. boot F17 Alpha install, go through the installer
2. at partitioning step, uncheck LVM, choose to modify the scheme
3. ... what I did:
a) merged all ext4 partitions (i.e. removed /boot and /home, enlarged / to fill all remaining space)
b) increased swap size
this left me with:
sda1 - the wasted space for the thing that never works (just google for user stories)
sda2 - swap
sda3 - /
4. install
5. reboot
6. stare at the screen
  
Actual results:
6. blank, blank, just blank ... the system does NOT boot

Expected results:
6. Fedora 17 boots without any problem and finishes post-install tasks

Additional info:
the hardware is Lenovo IdeaPad B570e

trying to boot from the install media again and choosing "Boot from local drive" only leads to

Booting from local disk...

Boot failed: please change disks and press a key to continue.
Comment 1 Chris Lumens 2012-03-23 10:18:37 EDT
You need to attach log files to this bug report.  After installation, you can find them in /var/log/anaconda.  Without them we can't do anything for you.
Comment 2 Karel Volný 2012-03-23 11:34:59 EDT
Created attachment 572316 [details]
anaconda logs
Comment 3 Chris Lumens 2012-03-23 11:38:59 EDT
Please attach them as individual, uncompressed files.  Doing anything else prevents us from being able to search bugzilla later.  I've noticed a ton of people doing this lately.  Are you reading somewhere that it's the preferred method?  If so, we really need to get that changed.
Comment 4 Karel Volný 2012-03-29 06:44:43 EDT
Created attachment 573623 [details]
anaconda.ifcfg.log
Comment 5 Karel Volný 2012-03-29 06:45:05 EDT
Created attachment 573624 [details]
anaconda.log
Comment 6 Karel Volný 2012-03-29 06:45:28 EDT
Created attachment 573625 [details]
anaconda.program.log
Comment 7 Karel Volný 2012-03-29 06:45:54 EDT
Created attachment 573626 [details]
anaconda.storage.log
Comment 8 Karel Volný 2012-03-29 06:46:20 EDT
Created attachment 573627 [details]
anaconda.syslog
Comment 9 Karel Volný 2012-03-29 06:46:46 EDT
Created attachment 573628 [details]
anaconda.xlog
Comment 10 Karel Volný 2012-03-29 06:47:22 EDT
Created attachment 573629 [details]
anaconda.yum.log
Comment 11 Karel Volný 2012-03-29 06:51:53 EDT
(In reply to comment #3)
> Please attach them as individual, uncompressed files.  Doing anything else
> prevents us from being able to search bugzilla later.

sorry, I was unaware of the fact that the contents of the attachments is searchable in Bugzilla

> I've noticed a ton of people doing this lately.  Are you reading somewhere
> that it's the preferred method?

no, it is just easier by orders of magnitude to attach/download one small file than dozens of separate uncompressed ones ...

> If so, we really need to get that changed.

... I guess the above implies that what needs to be done is RFE for Bugzilla to make bulk uploads easier & utilise transfer compression
Comment 12 Brian Lane 2013-05-07 19:11:19 EDT
F17 is long past, hopefully this works now.

Note You need to log in before you can comment on or make changes to this bug.