Bug 806346 - Update to latest stable version 1.0.x
Update to latest stable version 1.0.x
Status: CLOSED NOTABUG
Product: Fedora EPEL
Classification: Fedora
Component: nginx (Show other bugs)
el5
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jeremy Hinegardner
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-23 09:57 EDT by Pavel Lisý
Modified: 2012-03-23 12:53 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-23 12:53:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel Lisý 2012-03-23 09:57:44 EDT
Description of problem:

Is it possible to update nginx to latest stable version? 

With new 10 years support for RHEL5 it makes sense to update it (for more than next 3 years of these systems). 

Compilation is definitely possible. On http://nginx.org/en/download.html is repository for RHEL 5 with latest version (1.0.14) in it.

If you give rights I can help with it.
Comment 1 Jeremy Hinegardner 2012-03-23 12:53:18 EDT
Updating a major version of a package is, in the vast majority of cases, against the EPEL policy.

https://fedoraproject.org/wiki/EPEL/GuidelinesAndPolicies#A_major_version_update

"this update should be avoided if possible at all. If there really is no other way out to fix a serious bug then it rare cases it might be acceptable to build the new version for the testing branch and mention the update and the needed adjustments in the release notes for the next update. An additional compat- packages with the old libs is necessary if the ABI changed"


Since the 0.8.x branch of nginx is still supported by upstream, I think it is correct to keep it at this level for EPEL 5. Should a critical bug come through nginx that is not fixed in 0.8.x, or if 0.8.x goes out of support then it would be appropriate to update nginx in EPEL 5 to the 1.0.x releases.

For instance, if the recent security bug for nginx had not been fixed in 0.8, I would have updated nginx to 1.0.14.

-jeremy

Note You need to log in before you can comment on or make changes to this bug.