Bug 806360 - ipa-server TPS faling because memcached is missing, mod_ssl conflicts
ipa-server TPS faling because memcached is missing, mod_ssl conflicts
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ipa (Show other bugs)
6.3
Unspecified Unspecified
medium Severity high
: rc
: ---
Assigned To: Rob Crittenden
Namita Soman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-23 10:37 EDT by Jenny Galipeau
Modified: 2013-03-19 13:00 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-19 13:00:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jenny Galipeau 2012-03-23 10:37:43 EDT
Description of problem:

1) memcached is needed by ipa-server-2.2.0-5.el6.x86_64 mod_auth_kerb >= 5.4-8 is needed by ipa-server-2.2.0-5.el6.x86_64 

I have set the dependency on python-memcached properly but this does not resolve the error

2) mod_ssl conflicts with ipa-server-2.2.0-5.el6.x86_64

Version-Release number of selected component (if applicable):
ipa-server-2.2.0-5.el6

How reproducible:


Steps to Reproduce:
1.  Please errata test logs
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Rob Crittenden 2012-03-23 11:14:00 EDT
1. The requires for memcached and mod_auth_kerb have not changed since 2.2.0-3. Is this a new failure?

I looked but was unable to find any TPS errors related to mod_auth_kerb, memcached or python-memcached. Can you point out the error?

2. The mod_ssl Conflict is being discussed in BZ https://bugzilla.redhat.com/show_bug.cgi?id=804605

Without the Conflict then merely installing mod_ssl will break communication with the CA.
Comment 2 Jenny Galipeau 2012-03-27 13:09:13 EDT
Because IPA was getting respun a number of times, TPS issues were not addressed.  I suspect that this is not new.
Comment 3 Rob Crittenden 2012-03-27 13:40:20 EDT
Ok, but like I said, I didn't see any of the package errors in the logs. Can you please point them out?
Comment 4 Rob Crittenden 2012-04-04 15:45:31 EDT
For the record, the error we're seeing is:

memcached is needed by ipa-server-2.2.0-5.el6.x86_64

I talked to jwl in #errata about this. It is failing in the ComputeNode tree because it lacks memcached. We need product management approval for adding memcached to ComputeNode.

The mod_ssl Conflicts was removed, that test should be passing now.

I noticed these too, not sure if they are also ComputeNode related or not:

libpcre.so.0 is needed by 389-ds-base-libs-1.2.10.2-4.el6.i686 
libsvrcore.so.0 is needed by 389-ds-base-libs-1.2.10.2-4.el6.i686
Comment 5 Jenny Galipeau 2012-04-04 16:16:55 EDT
actual TPS error message output ::

139:error: Failed build dependencies: 
140- python-memcached is needed by ipa-2.2.0-8.el6.i686
Comment 12 Bill Nottingham 2012-04-10 11:04:38 EDT
(for Server, that is.)
Comment 15 Suzanne Yeghiayan 2012-05-14 15:03:08 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 17 RHEL Product and Program Management 2012-09-07 01:03:32 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.

Note You need to log in before you can comment on or make changes to this bug.