Bug 806371 - [REST API] links are a special construct, neither relative nor absolute
[REST API] links are a special construct, neither relative nor absolute
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Pod (Show other bugs)
2.x
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: Lili Nader
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-23 11:06 EDT by Andre Dietisheim
Modified: 2015-05-14 21:49 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-13 14:33:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andre Dietisheim 2012-03-23 11:06:02 EDT
If you GET a resource you'd get links to possible operations. those links use hrefs that are neither absolute nor relative. They're a value a client would have to add to the broker base url. In our sense this is not ideal since it requires the client library to know about a service base url:

<link>
    <href>/domains/1329997507457</href>
    <method>DELETE</method>
</link>

We'd strongly prefer absolute URL's since the logic behind resource URLs is then completely opaque for clients. They would not need any special knowledge about a base url, context or whatever.
Comment 1 Mrunal Patel 2012-03-26 18:44:29 EDT
Lowering priority since this could be addressed in a US.
Comment 2 Lili Nader 2012-04-09 16:10:15 EDT
changed all links to absolute
Comment 3 Xiaoli Tian 2012-04-12 06:37:37 EDT
(In reply to comment #2)
> changed all links to absolute

Tested it on devenv-stage-166, all links are absolute like following :
 <href>https://ec2-23-20-212-221.compute-1.amazonaws.com/broker/rest/domains/domx91/applications/scalephp1/cartridges</href>

Note You need to log in before you can comment on or make changes to this bug.