Bug 806375 - rhc-admin-chk flags apps that are fine as "does not exist on any node"
rhc-admin-chk flags apps that are fine as "does not exist on any node"
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Pod (Show other bugs)
2.x
Unspecified Unspecified
high Severity low
: ---
: ---
Assigned To: Rajat Chopra
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-23 11:10 EDT by Thomas Wiest
Modified: 2015-05-14 21:49 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-27 16:47:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Wiest 2012-03-23 11:10:22 EDT
Description of problem:
rhc-admin-chk flags apps that are fine as "does not exist on any node."

For instance, in STG, it says this about one of my apps:
Gear 10f90d2d524342c39ea598afd775ab85 in drupal does not exist on any node

But when I look, it's clearly still on ex-std-node1.stg.rhcloud.com.


It does this in PROD too. Here is one of my apps:
Gear 0dc36a4daa35429b9ad4a308695ef5d4 in jmigrate does not exist on any node

But when I look, it's still on ex-std-node11.prod.rhcloud.com


In STG it flags roughly 50% of apps. In PROD it flags roughly 90% of apps.


Version-Release number of selected component (if applicable):
rhc-broker-0.88.10-1.el6_2.noarch


How reproducible:
Very


Steps to Reproduce:
1. Run rhc-admin-chk
2. Take one of the results from the output and look for that app on a node
3. Notice that that app is still on a node
  

Actual results:
Flags apps that are fine as "does not exist on any node".


Expected results:
It should only flag apps that have issues.
Comment 1 Rajat Chopra 2012-03-29 22:56:27 EDT
Cant reproduce this bug on devenv. 
Possible theoretical reasons are : timeout on mcollective calls, truncation of data because of size.

Need help with getting on the stg env to debug.

Not fixing this in Sprint #8.
Comment 2 Thomas Wiest 2012-03-29 23:13:18 EDT
Ok, sounds good. Ping me after the release to PROD and you and I can go through this in STG or PROD together.

Thanks :)
Comment 3 Rajat Chopra 2012-04-02 19:00:15 EDT
Fixed with rev#ab7f57f1414516ab70795cdf44684f79b13bd988
Comment 4 Johnny Liu 2012-04-06 05:06:23 EDT
Hi Thomas,

For QE, it is difficult to reproduce this issue, and verify it.
Can you help to verify it? If it passed, please help move this bug to "Verified".


Thanks
Comment 5 Thomas Wiest 2012-04-09 10:53:37 EDT
Sure. It hasn't been pushed in to STG yet (that will happen later this week), and once it is, then I'll verify it.
Comment 6 Thomas Wiest 2012-04-13 15:08:52 EDT
I verified that this bug is fixed in STG.

Note You need to log in before you can comment on or make changes to this bug.