Bug 806377 - VM fails to run in RHEVM Power User Portal due to I/O error in libvirt
Summary: VM fails to run in RHEVM Power User Portal due to I/O error in libvirt
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Virtualization Tools
Classification: Community
Component: libvirt
Version: unspecified
Hardware: Unspecified
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Libvirt Maintainers
QA Contact: Pavel Novotny
URL:
Whiteboard:
Depends On:
Blocks: 809130
TreeView+ depends on / blocked
 
Reported: 2012-03-23 15:14 UTC by Pavel Novotny
Modified: 2012-04-05 10:02 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 809130 (view as bug list)
Environment:
Last Closed: 2012-04-05 10:02:51 UTC


Attachments (Terms of Use)
libvirt I/O error (2.49 KB, text/plain)
2012-03-23 15:14 UTC, Pavel Novotny
no flags Details

Description Pavel Novotny 2012-03-23 15:14:27 UTC
Created attachment 572302 [details]
libvirt I/O error

Description of problem:
When trying to run VM via Red Hat Enterprise Virtualization Manager (RHEVM) - Power User Portal, the VM fails to start due to an I/O error in libvirt, which cannot access VM disk image header, stored on NFS data storage.

Version-Release number of selected component (if applicable):
libvirt-0.9.10-5.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
1. In RHEVM, create a Desktop or Server VM (use 'Blank' template) on NFS data storage.
2. Add an empty disk to it (sub-tab Virtual Disks -> New). Use Disk type = System, Interface = VirtIO.
3. Wait until the disk is initialized and run VM.
  
Actual results:
In RHEVM, VM state changes from "Down" -> "Waiting to Launch" and after few seconds back to "Down". 
On host machine - libvirt returns "Input/output error", see Additional info, full log is in attachment.

Expected results:
VM should start properly.


Additional info:

/var/log/libvirt/libvirtd.log:
==============================
2012-03-19 15:24:40.244+0000: 17151: error : virNetClientProgramDispatchError:174 : cannot read header '/rhev/data-center/afdbdbce-74ae-40ee-bb1d-fd0721ecd502/f5353edf-097d-4400-bfdf-ffb853b0be5f/images/3df29012-8cac-4b3e-83c3-935042e699e9/304af6dd-959d-404a-8dd2-2b7f5904f1b3': Input/output error
==============================

*Regression* against libvirt-0.9.4-23.el6_2.4.

Comment 1 Pavel Novotny 2012-04-05 10:02:51 UTC
Closing as NOTABUG, see https://bugzilla.redhat.com/show_bug.cgi?id=809130#c4.


Note You need to log in before you can comment on or make changes to this bug.