Bug 806441 - Newsgroups not working anymore
Newsgroups not working anymore
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: thunderbird (Show other bugs)
16
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Jan Horak
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-23 14:35 EDT by Piergiorgio Sartor
Modified: 2012-03-28 12:03 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-28 12:03:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Piergiorgio Sartor 2012-03-23 14:35:26 EDT
Description of problem:
Since some version of "thunderbird", the usenet news(groups) are not anymore readable.

Version-Release number of selected component (if applicable):
thunderbird-11.0-5.fc16.x86_64

How reproducible:
Always

Steps to Reproduce:
1.
Start "thunderbird -jsconsole -safe-mode"
2.
Try to access a *subscribed* newsgroup

Actual results:
Nothing happens.

Expected results:
The newsgroup should be accessed and the message list displayed

Additional info:
Error console output while trying to read news:

Timestamp: 03/23/2012 07:23:37 PM
Error: uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIMsgFolder.updateFolder]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: resource:///modules/dbViewWrapper.js :: FolderNotificationHelper_notifyOnLoad :: line 131"  data: no]

The news server is "localhost", using "leafnode".
This was working in the past and it still works with "slrn" and, of course, "telnet localhost 119".

Checking with "netstat -t" does not show any connection to "localhost:119" when using TB. Of course, with "slrn" the connection shows up.

Finally, even trying to subscribe to a new newsgroup does not show any connection to "localhost:119" and it simply waits forever. No new error in console appears.

I can suspect a local issue (some DB corruption, maybe?), but I've no idea on how to debug any further.

Thanks,

bye,

pg
Comment 1 Piergiorgio Sartor 2012-03-23 14:37:37 EDT
Well, some more last minute news.

The error console show:

Timestamp: 03/23/2012 07:36:40 PM
Error: uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIMsgIncomingServer.performExpand]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: chrome://messenger/content/mailWindowOverlay.js :: GetFolderMessages :: line 2419"  data: no]

When trying "Get messages" from the News pull down menu.

bye,

pg
Comment 2 Jan Horak 2012-03-27 09:17:09 EDT
Sorry, I can't reproduce such behaviour. Do you have by any chance proxy set in gnome-control-center/Network/Network proxy?

Gnome 3 proxy setting is accepted since Thunderbird 11. It shouldn't work on localhost connection though.

Please attach also output of (don't forget check output for sensitive information!):
gsettings list-recursively org.gnome.system.proxy
Comment 3 Piergiorgio Sartor 2012-03-27 14:07:23 EDT
Hi Jan,

thanks for the answer.

I suspect it is a "local" problem, maybe some database file is damaged or the like, that's why you cannot reproduce.

There is no proxy setting. First of all the problem showed up already in TB 9 or 8, second I've a local IMAP server, and this works fine, I can read emails.
Finally, the configuration tool and gsettings do not report any proxy.

org.gnome.system.proxy autoconfig-url ''
org.gnome.system.proxy ignore-hosts ['localhost', '127.0.0.0/8']
org.gnome.system.proxy mode 'none'
org.gnome.system.proxy use-same-proxy false
org.gnome.system.proxy.ftp host ''
org.gnome.system.proxy.ftp port 0
org.gnome.system.proxy.http authentication-password ''
org.gnome.system.proxy.http authentication-user ''
org.gnome.system.proxy.http enabled false
org.gnome.system.proxy.http host ''
org.gnome.system.proxy.http port 0
org.gnome.system.proxy.http use-authentication false
org.gnome.system.proxy.https host ''
org.gnome.system.proxy.https port 0
org.gnome.system.proxy.socks host ''
org.gnome.system.proxy.socks port 0

One problem could be the difficulties I've in debugging it.

TB does not seem to offer some "verbose" mode or similar in order to understand where exactly the problem happens.

So, if you've any suggestions on how I could try to get more information out of TB, it would be really appreciated!

For example, what are those .js modules reported by the error console?

Thanks,

bye,

pg
Comment 4 Piergiorgio Sartor 2012-03-27 14:31:20 EDT
Hi,

maybe one more discovery.

Deleting the TB user folder (the one with pseudo random name) seems to restore the NNTP connection capabilities.

Now, I would like to fix it without re-creating everything, especially the email account.

Which files are used by the news reader?

I might consider to delete only those.

Thanks,

bye,

pg
Comment 5 Piergiorgio Sartor 2012-03-27 14:44:17 EDT
Hi again,

OK, it seems "prefs.js" has problems.

Deleting only this file restores the news reader, but, of course, all other settings (email account and so on) are lost...

Any idea, from the error console log, on what could it be?

bye,

pg
Comment 6 Piergiorgio Sartor 2012-03-27 15:24:03 EDT
Hi,

finally it seems I solved the issue.

I do not know the reason, but re-creating a second news group account worked.
So, after that, it was enough to delete the old one.

I guess you can close this report, if you like.

Thanks,

bye,

pg
Comment 7 Jan Horak 2012-03-28 12:03:41 EDT
Okay, thanks for letting us know. 

Btw you can build thunderbird debug package which shows much more debugging info than one we ship. To create such package you have to build our own rpm by changing thunderbird.spec in thunderbird's srpm following line:
%define debug_build 1
It's a little bit complicated and I'm going to write some instructions about this subject some day.

Note You need to log in before you can comment on or make changes to this bug.