Bug 806484 - [abrt] blueman-1.21-10.fc16: utils.py:28:warp:DBusException: org.freedesktop.DBus.Error.UnknownMethod: Method "SetProperty" with signature "sb" on interface "org.bluez.Adapter" doesn't exist
[abrt] blueman-1.21-10.fc16: utils.py:28:warp:DBusException: org.freedesktop....
Status: CLOSED DUPLICATE of bug 770434
Product: Fedora
Classification: Fedora
Component: blueman (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Juan Manuel Rodriguez
Fedora Extras Quality Assurance
abrt_hash:038e44c4d12b325155c0e1c6be9...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-23 18:46 EDT by Daniel Mack
Modified: 2012-04-26 18:55 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-26 18:55:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Mack 2012-03-23 18:46:26 EDT
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        /usr/bin/python /usr/bin/blueman-applet
comment:        happened when the machine was idle.
executable:     /usr/bin/blueman-applet
kernel:         3.2.7-1.fc16.x86_64
reason:         utils.py:28:warp:DBusException: org.freedesktop.DBus.Error.UnknownMethod: Method "SetProperty" with signature "sb" on interface "org.bluez.Adapter" doesn't exist
time:           Fr 23 Mär 2012 19:53:59 CET
uid:            500
username:       daniel

backtrace:
:utils.py:28:warp:DBusException: org.freedesktop.DBus.Error.UnknownMethod: Method "SetProperty" with signature "sb" on interface "org.bluez.Adapter" doesn't exist
:
:
:Traceback (most recent call last):
:  File "/usr/lib/python2.7/site-packages/blueman/plugins/applet/KillSwitch.py", line 77, in on_switch_changed
:    self.Applet.Plugins.PowerManager.SetBluetoothStatus(False)
:  File "/usr/lib/python2.7/site-packages/blueman/plugins/applet/PowerManager.py", line 55, in SetBluetoothStatus
:    self.bluetooth_off = not status
:  File "/usr/lib/python2.7/site-packages/blueman/plugins/applet/PowerManager.py", line 147, in __setattr__
:    set_global_state()
:  File "/usr/lib/python2.7/site-packages/blueman/plugins/applet/PowerManager.py", line 123, in set_global_state
:    adapter.SetProperty("Powered", not value)
:  File "/usr/lib/python2.7/site-packages/blueman/bluez/utils.py", line 28, in warp
:    raise errors.parse_dbus_error(exception)
:DBusException: org.freedesktop.DBus.Error.UnknownMethod: Method "SetProperty" with signature "sb" on interface "org.bluez.Adapter" doesn't exist
:
:
:Local variables in innermost frame:
:exception: DBusException('Method "SetProperty" with signature "sb" on interface "org.bluez.Adapter" doesn\'t exist\n',)
:args: (<blueman.bluez.Adapter.Adapter object at 0x22c6110>, 'Powered', False)
:func: <function SetProperty at 0x1f4d668>
:kwargs: {}
Comment 1 Christoph Wickert 2012-04-26 18:55:18 EDT

*** This bug has been marked as a duplicate of bug 770434 ***

Note You need to log in before you can comment on or make changes to this bug.