Bug 806500 - mediacheck on install images (DVD and netinst) is well hidden
mediacheck on install images (DVD and netinst) is well hidden
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-24 01:45 EDT by Andre Robatino
Modified: 2012-03-31 22:24 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-31 22:24:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andre Robatino 2012-03-24 01:45:25 EDT
Description of problem:
Booting from recent TCs/RCs including 17 Beta RC1, the installer no longer offers a mediacheck. I also tried boot options "mediacheck" and "inst.mediacheck" and neither of those do anything. I haven't checked the behavior of live images.

Version-Release number of selected component (if applicable):
whatever is in 17 Beta RC1

How reproducible:
always
Comment 1 Chris Lumens 2012-03-25 20:26:38 EDT
I don't know what Will might have in mind for this given the no loader stuff, but I've definitely got it covered for the new UI in F18 if nothing happens for F17.
Comment 2 Andre Robatino 2012-03-26 15:40:58 EDT
While on the topic, what is the status of mediacheck on the netinst images? I know it's been gone for a while, but it would be nice to be able to have a Final criterion requiring a mediacheck on all images (netinst, DVD, and live). The current criterion only says "If there is embedded checksum on ISO media, it must be correct." but most people probably don't know how to do an external check.
Comment 3 Andre Robatino 2012-03-29 04:38:31 EDT
According to https://lists.fedoraproject.org/pipermail/test/2012-March/106409.html :

If you pass 'check' on the cmdline dracut will run a mediacheck. We may
want to add a menu option for that under Troubleshooting.

I confirmed that this works for both DVD and netinst images (which I thought didn't have a mediacheck any more). I think it would be better to make this default and have a "nocheck" option instead, as Adam suggests in the followup message. In fact I think this should happen for live images as well. Having the DVD, netinst and live images all check themselves automatically could prevent a lot of destructive installation/upgrade failures.
Comment 4 Andre Robatino 2012-03-31 22:24:31 EDT
Closing since the mediacheck exists. I might open another bug as an RFE though.

Note You need to log in before you can comment on or make changes to this bug.