Bug 806506 - boot into VNC installation with serial
boot into VNC installation with serial
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Will Woods
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-24 05:37 EDT by Hongqing Yang
Modified: 2012-04-05 00:12 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-05 00:12:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hongqing Yang 2012-03-24 05:37:33 EDT
Description of problem:

Got the following information when install system with kernel parameters:
'console=ttyS0,115200n8'

09:33:13 Starting VNC...                                                       
09:33:14 The VNC server is now running.
09:33:14 

You chose to execute vnc with a password. 


09:33:14 Please manually connect your vnc client to 10.66.13.64:1 to begin the install.
09:33:15 Starting graphical installation.

** WARNING **: Trying to register gtype 'GMountMountFlags' as enum when in fact it is of type 'GFlags'

** WARNING **: Trying to register gtype 'GDriveStartFlags' as enum when in fact it is of type 'GFlags'

Version-Release number of selected component (if applicable):


How reproducible:

50%

Steps to Reproduce:
1. boot system
2. type kernel parameter 'console=ttyS0,115200n8'
3.
  
Actual results:


Expected results:
install system with kernel parameter

Additional info:
Comment 1 Hongqing Yang 2012-03-25 22:41:03 EDT
The problem is that I watch the serial port too late, the system will choose VNC instead of Text Mode. I am not if it is intended to be designed like this or not. So not sure if it is a bug.
Comment 2 Adam Williamson 2012-03-26 18:40:07 EDT
When you do a text mode install, it pops up a dialog right at the start saying that text mode is not recommended and asking if you want to use VNC instead. the default choice is VNC.

so I wonder if this dialog has a (non-declared) timeout, and any time you leave anaconda sitting at that stage for a while, it'll wind up doing a VNC install?



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 3 Hongqing Yang 2012-03-27 00:41:44 EDT
(In reply to comment #2)
> When you do a text mode install, it pops up a dialog right at the start saying
> that text mode is not recommended and asking if you want to use VNC instead.
> the default choice is VNC.
> 
> so I wonder if this dialog has a (non-declared) timeout, and any time you leave
> anaconda sitting at that stage for a while, it'll wind up doing a VNC install?
> 
yeah, so I not sure if it is a bug or intended to be designed like this.
Comment 4 Hongqing Yang 2012-04-05 00:12:40 EDT
fixed in F17 Beta RC3

Note You need to log in before you can comment on or make changes to this bug.