Bug 806563 - Wifi connection speed is very slow (intel PRO/Wireless 4945 AGN)
Wifi connection speed is very slow (intel PRO/Wireless 4945 AGN)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Stanislaw Gruszka
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-24 16:21 EDT by Javier Jardón
Modified: 2012-04-22 15:59 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-18 14:49:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg (69.25 KB, text/plain)
2012-04-01 21:23 EDT, Javier Jardón
no flags Details

  None (edit)
Description Javier Jardón 2012-03-24 16:21:54 EDT
Also, seems I get Tx excessive retries:

wlan0     IEEE 802.11abgn  ESSID:"house"  
          Mode:Managed  Frequency:2.437 GHz  Access Point: C0:3F:0E:F9:AE:4B   
          Bit Rate=144.4 Mb/s   Tx-Power=15 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=46/70  Signal level=-64 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:2435  Invalid misc:24   Missed beacon:0
Comment 1 Javier Jardón 2012-03-24 16:35:07 EDT
Maybe a regresion of bug #708747 ?
Comment 2 Javier Jardón 2012-03-25 07:51:37 EDT
Confirming the regression. If I put

options iwl4965 11n_disable=1 in /etc/modprobe.d/iwl4965-disable11n.conf

solved the problem here
Comment 3 Stanislaw Gruszka 2012-03-27 05:27:28 EDT
If this is regression please provide the latest kernel version you know that it work.
Comment 4 Stanislaw Gruszka 2012-03-30 05:03:27 EDT
So, what is the latest working kernel version ?
Comment 5 Javier Jardón 2012-03-30 05:52:18 EDT
Sorry for the delay Stanislaw.

This never worked to me since I installed F17.
Unfortunately, In this machine I switch directly from F15 (kernel-2.6.42.12-1.fc15) to a clean F17 snapshop installation.
Comment 6 Stanislaw Gruszka 2012-03-30 06:12:38 EDT
Ok, 2.6.42 is renamed 3.2, so this is 3.2 -> 3.3 regression. Can remove temporally 11n_disable option and provide dmesg, I would like to see if there is some obvious reason of breakage.
Comment 7 Javier Jardón 2012-04-01 21:23:18 EDT
Created attachment 574389 [details]
dmesg
Comment 8 Stanislaw Gruszka 2012-04-02 03:45:21 EDT
There is no information in dmesg which indicate any problem.

Also "Tx excessive retries" do not indicate any particular problem, i.e. I have lot of them and performance on my 4965 is good.

I wonder if this is problem caused by kernel change or some other things change that bug can be observable on f17 and was not on f15.

Could you install 3.2 f16 kernel, and check if it do not have this problem. You could download this kernel:
http://koji.fedoraproject.org/koji/buildinfo?buildID=307526
and install it with "rpm -ivh --force"

Also I need some more information about your wireless connection: AP model, it's configuration like security settings, channel used, anything that could be useful to reproduce the issue.
Comment 9 Stanislaw Gruszka 2012-04-04 06:46:10 EDT
Please provide info requested in above comment.
Comment 10 Javier Jardón 2012-04-09 18:29:43 EDT
Sorry for the delay, I was in holidays

I tried 3.2 f16 kernel, but the problem persist. I also tried the latest 2.6 from fc15 and It works without problems.

AP model: netgear CG3300D: http://support.netgear.com/app/products/model/a_id/12788
security: WPA2 / CCMP (AES)
channel: 11
Comment 11 Javier Jardón 2012-04-09 18:44:09 EDT
Sorry, the AP model is a Netgear VMDG280, the one provided by Virgin in UK.
Comment 12 Stanislaw Gruszka 2012-04-10 01:59:28 EDT
(In reply to comment #10)
>I also tried the latest 2.6
> from fc15 and It works without problems.

Which 2.6.y exacly ?
Comment 13 Stanislaw Gruszka 2012-04-10 02:27:23 EDT
Did you use it on f17 user space ?

I just realized that VMDG280 are available on eBay with very low price, so I'll order one.
Comment 14 Javier Jardón 2012-04-10 08:53:28 EDT
(In reply to comment #13)
> Did you use it on f17 user space ?

yes.

The version is kernel-2.6.43.1-2.fc15 ( http://koji.fedoraproject.org/koji/buildinfo?buildID=311365 )
Comment 15 Javier Jardón 2012-04-18 11:39:33 EDT
Stanislaw,

I updated to a new kernel (3.3.1-5) and the problem seems to be fixed here. I can try olders kernel to know exactly when It gets fixed if you want.
Feel free to close this bug report and thanks for your support.
Comment 16 Stanislaw Gruszka 2012-04-18 14:49:06 EDT
Hmm, I just win the VMDG280 bid on ebay, so I'll have yet another AP for testing, however I wish to collect APs that do not work with linux wireless stack.

Anyway, I'm happy it works :-)

One more question just in case, did you remove 11n_disable=1 option on new kernel?
Comment 17 Javier Jardón 2012-04-22 15:59:46 EDT
(In reply to comment #16)
> Hmm, I just win the VMDG280 bid on ebay, so I'll have yet another AP for
> testing, however I wish to collect APs that do not work with linux wireless
> stack.
>
> Anyway, I'm happy it works :-)

Yeah, me too ;)

> One more question just in case, did you remove 11n_disable=1 option on new
> kernel?

Rechecked only in case today: yeah I have commented the line

Note You need to log in before you can comment on or make changes to this bug.