Bug 806573 - [abrt] deluge-gtk-1.3.3-1.fc16: sessionproxy.py:132:get_torrent_status:KeyError: 'upload_payload_rate'
[abrt] deluge-gtk-1.3.3-1.fc16: sessionproxy.py:132:get_torrent_status:KeyErr...
Status: CLOSED DUPLICATE of bug 759828
Product: Fedora
Classification: Fedora
Component: deluge (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rahul Sundaram
Fedora Extras Quality Assurance
abrt_hash:dd2817afe6f66b94780a75750c8...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-24 18:31 EDT by Victor Ion Munteanu
Modified: 2012-03-27 08:11 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-27 08:11:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: smolt_data (4.88 KB, text/plain)
2012-03-24 18:32 EDT, Victor Ion Munteanu
no flags Details

  None (edit)
Description Victor Ion Munteanu 2012-03-24 18:31:56 EDT
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        /usr/bin/python /usr/bin/deluge-gtk /tmp/[SceneFZ.net]Game.of.Thrones.S2E00.You.Win.or.You.Die.720p.WEB-DL.H264-P2P.torrent
executable:     /usr/bin/deluge-gtk
kernel:         3.2.10-3.fc16.x86_64
reason:         sessionproxy.py:132:get_torrent_status:KeyError: 'upload_payload_rate'
time:           Sun 25 Mar 2012 12:31:24 AM EET
uid:            1000
username:       nemros

smolt_data:     Text file, 5000 bytes

backtrace:
:sessionproxy.py:132:get_torrent_status:KeyError: 'upload_payload_rate'
:
:Traceback (most recent call last):
:  File "/usr/lib/python2.7/site-packages/deluge/ui/gtkui/torrentview.py", line 534, in on_selection_changed
:    component.get("TorrentDetails").update()
:  File "/usr/lib/python2.7/site-packages/deluge/ui/gtkui/torrentdetails.py", line 367, in update
:    self.tabs[name].update()
:  File "/usr/lib/python2.7/site-packages/deluge/ui/gtkui/status_tab.py", line 120, in update
:    selected, status_keys).addCallback(self._on_get_torrent_status)
:  File "/usr/lib/python2.7/site-packages/deluge/ui/sessionproxy.py", line 132, in get_torrent_status
:    if time.time() - self.cache_times[torrent_id][key] > self.cache_time:
:KeyError: 'upload_payload_rate'
:
:Local variables in innermost frame:
:keys: ['progress', 'num_pieces', 'piece_length', 'distributed_copies', 'all_time_download', 'total_payload_download', 'total_uploaded', 'total_payload_upload', 'download_payload_rate', 'upload_payload_rate', 'num_peers', 'num_seeds', 'total_peers', 'total_seeds', 'eta', 'ratio', 'next_announce', 'tracker_status', 'max_connections', 'max_upload_slots', 'max_upload_speed', 'max_download_speed', 'active_time', 'seeding_time', 'seed_rank', 'is_auto_managed', 'time_added']
:torrent_id: '5b3989c93cac8f4480e77bedb55a0e70b3b727d5'
:self: <deluge.ui.sessionproxy.SessionProxy object at 0x30d8450>
:keys_to_get: []
:key: 'upload_payload_rate'
Comment 1 Victor Ion Munteanu 2012-03-24 18:32:02 EDT
Created attachment 572467 [details]
File: smolt_data
Comment 2 Calum 2012-03-27 08:11:49 EDT

*** This bug has been marked as a duplicate of bug 759828 ***

Note You need to log in before you can comment on or make changes to this bug.