Bug 806582 - SELinux is preventing systemd-logind from 'unlink' accesses on the fifo_file 2.ref.
SELinux is preventing systemd-logind from 'unlink' accesses on the fifo_file ...
Status: CLOSED DUPLICATE of bug 804235
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:e7dc281ce031568717be716fc12...
:
: 806583 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-24 21:18 EDT by Horst H. von Brand
Modified: 2012-03-26 09:27 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-26 09:27:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Horst H. von Brand 2012-03-24 21:18:19 EDT
libreport version: 2.0.8
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.2.9-2.fc16.x86_64
reason:         SELinux is preventing systemd-logind from 'unlink' accesses on the fifo_file 2.ref.
time:           Sat 24 Mar 2012 10:17:54 PM CLST

description:
:SELinux is preventing systemd-logind from 'unlink' accesses on the fifo_file 2.ref.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that systemd-logind should be allowed unlink access on the 2.ref fifo_file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep systemd-logind /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:systemd_logind_t:s0
:Target Context                system_u:object_r:init_var_run_t:s0
:Target Objects                2.ref [ fifo_file ]
:Source                        systemd-logind
:Source Path                   systemd-logind
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-75.fc16.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.2.9-2.fc16.x86_64 #1
:                              SMP Mon Mar 5 20:55:39 UTC 2012 x86_64 x86_64
:Alert Count                   3
:First Seen                    Sat 24 Mar 2012 10:14:33 PM CLST
:Last Seen                     Sat 24 Mar 2012 10:16:26 PM CLST
:Local ID                      538f80ba-f77c-4bd7-9fc7-5b5cfbf92936
:
:Raw Audit Messages
:type=AVC msg=audit(1332638186.734:203): avc:  denied  { unlink } for  pid=2797 comm="systemd-logind" name="2.ref" dev=tmpfs ino=29846 scontext=system_u:system_r:systemd_logind_t:s0 tcontext=system_u:object_r:init_var_run_t:s0 tclass=fifo_file
:
:
:Hash: systemd-logind,systemd_logind_t,init_var_run_t,fifo_file,unlink
:
:audit2allow
:
:#============= systemd_logind_t ==============
:allow systemd_logind_t init_var_run_t:fifo_file unlink;
:
:audit2allow -R
:
:#============= systemd_logind_t ==============
:allow systemd_logind_t init_var_run_t:fifo_file unlink;
:
Comment 1 Miroslav Grepl 2012-03-26 06:58:58 EDT
*** Bug 806583 has been marked as a duplicate of this bug. ***
Comment 2 Miroslav Grepl 2012-03-26 09:27:38 EDT

*** This bug has been marked as a duplicate of bug 804235 ***

Note You need to log in before you can comment on or make changes to this bug.