Bug 806600 - [abrt] xfce4-power-manager-1.0.10-3.fc17: Process /usr/bin/xfce4-power-manager was killed by signal 11 (SIGSEGV)
[abrt] xfce4-power-manager-1.0.10-3.fc17: Process /usr/bin/xfce4-power-manage...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: xfce4-power-manager (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Christoph Wickert
Fedora Extras Quality Assurance
abrt_hash:2bb71a58f8e3b63d1253268873d...
:
: 751121 805528 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-25 06:07 EDT by Christoph Wickert
Modified: 2012-06-29 12:34 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-04 03:59:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dso_list (6.70 KB, text/plain)
2012-03-25 06:07 EDT, Christoph Wickert
no flags Details
File: coredump (11.71 MB, text/plain)
2012-03-25 06:09 EDT, Christoph Wickert
no flags Details
File: maps (32.61 KB, text/plain)
2012-03-25 06:09 EDT, Christoph Wickert
no flags Details
File: backtrace (20.63 KB, text/plain)
2012-03-25 06:09 EDT, Christoph Wickert
no flags Details

  None (edit)
Description Christoph Wickert 2012-03-25 06:07:25 EDT
libreport version: 2.0.8
abrt_version:   2.0.7
backtrace_rating: 4
cmdline:        xfce4-power-manager
comment:        After upgrading to F17, xfce4-power-manager crashes every time when waking up from suspend. 
crash_function: xfpm_battery_get_message_from_battery_state
executable:     /usr/bin/xfce4-power-manager
kernel:         3.3.0-1.fc17.x86_64
pid:            15533
pwd:            /
reason:         Process /usr/bin/xfce4-power-manager was killed by signal 11 (SIGSEGV)
time:           Sa 24 Mär 2012 17:46:29 CET
uid:            1000
username:       chris
xsession_errors: 

backtrace:      Text file, 21126 bytes
dso_list:       Text file, 6865 bytes
maps:           Text file, 33390 bytes

build_ids:
:63651cdc0224824a9c9324c77c3b5887378e871d
:73d0aa1681b513d1459b8d6e6eac95cc131868bb
:51695fca087c8502a7552a94df36c944cdf74fd1
:6a6f7e91aa12548505e8302f27282865ff2842d3
:54a5cc118d928470da13565de8592b664a9868e0
:f6d72221cbd08cb36bb88823d33deb2024f2bee3
:2a19651717ca94078d6f064b28d9f7f4985de0ae
:f813375cba5b47aac7576dfddc1d9f8f056ee895
:b8bfc491895389962d926fdc99cbfbac571f2cf0
:ba411626ac13091abd42b787a74e754ac0188c13
:b277af36744327e3d58eae76bcdaadcca71a28c6
:a8efbe1d263ad42afae74bc027eee88eaa754f55
:f4d479614b09460085428bbe7d53df454d0d39e5
:8a58512c2cc89530f70932553442289158de3083
:e8e91030a190ea4578f1cbdc93b8dad0a2736653
:b1e3a6defd2119a017e2c5b43fbaf7d48d46a9cd
:cb561771554f57263ee5c9fe3f49f7279ef278e2
:2c09a3f87a92231b0acabb79968d235d61c36967
:e91010b497ec024178c36f4365b21f668bada0ca
:348363b75ba2150fca6a94fb3331dfc75a4f026b
:3e9f65a1ee01419219fb006790eb394dab35d0b7
:4d9f1e9a6e14bb126793e5796a5951874dd83038
:5bbbe16527d496a0e0fefc6ba0c0219a71a0e4c1
:7c35310fc506498c612d5d982ab03becc4b4817c
:657855175bdd1a6a2a52f1b51fd5b8a1afe2efcd
:d23ad34ab62b74ab51eb61de167b89aac5fcdc34
:1d4df97fa6024b097b634a272447243c95c26d85
:247132297f287226a24c12e683292f5c94013066
:8e283d5e8a5d6fc31e0d3d4e368a8ab855b39eea
:97317d1518e70c97ab14100f4510f2360865cbc3
:8b560a087d55fa23a60cfe9cdfca3b286ace988b
:4f9a85443f33acbad2eb0068b0d8128b38944b9f
:1c1cbb11b6d1c924bc72f2703a3077f89cd1e5b6
:b5797b67e070ac4ccaff8d7180cf635fa0f31cbf
:766fa7124150058af0f9ce4c39148868b4dbb47f
:3dd28f8a8b722d6f4d332bc688cc6b8a93f1cf16
:404cbecd24d186758ed474b345313da28b2990fa
:e850c9c2577f79b97ad4c53dbf9b0964682dcbaa
:5bc2d347a293d92e3c373d09875abb8a267a9fc4
:5366e8facadcf2b3d23752c71ff3eecd54a9cf2f
:dd2a83493c6dc6cfb58cf6edcde0fab0e1ad9ea3
:ce246b3297de0d233ac2c5f9e50061e2b13a330c
:a9eb9e4d2da6b047bad0601ad65f06ea8afb3603
:652697d945b4084f8ecf3bbd2eeb5d33b69aff4f
:80dcf30321dbc04511d9cbf399a83b8f3dc75d5d
:f0b8e665d56d250c2b4abc39c6d1d557ee623477
:a095f564bf20c90a6e26a32fe83d4d04c5eadbcb
:666abf228c966f37766ad17cd64ba794136e9ac9
:d804f8ee47797da9213a92f00cd095ecada8d79f
:8202c54356f3fdd1015ceb06235fba19b45d3fff
:de8765a1f811be7af865204ba32ef7846307e863
:4b044fe80e4c1b69986abc4b160c303048005d4e
:1fa4aa0f57b72034546fd97a1e0520e7d6502e0d
:277d74794a8d683ef066f298ec72b16b3a5ea5b2
:2e9c83ca984afb608a9c0e27ab8dd0b0c4f89746
:4dac977c0337ed949981bfc9ec0c5c617eb0cc74
:271a2d91cc3308783ff4a7ab45049f31aa42d8b7
:822e9b3523e8312240f41a25722d539bc77ed436
:f0264e76a3f8ec444874b1a23d68c2ecaeba5e1c
:7a19fd8074fd835024c84b4e6725f7827f3178a3
:76fae8d5d0d0171cf039cff5c0eeaa58fc592df9
:3aa364e64dd370c14adc27be6df2d70960406d7e
:46fe2763c4865dc6cd3b28818e63f42f4e3b0139
:cb4d385c55c522feae9fb39650f6f365f568796c

environ:
:XDG_VTNR=1
:XDG_SESSION_ID=2
:SSH_AGENT_PID=1199
:HOSTNAME=thinkmatic.localdomain
:GPG_AGENT_INFO=/home/chris/.gnupg/S.gpg-agent:1225:1
:GLADE_PIXMAP_PATH=:
:XDG_MENU_PREFIX=xfce-
:SHELL=/bin/bash
:HISTSIZE=1000
:XDG_SESSION_COOKIE=5e0ea2c735e2c8b572c974c600000022-1332572831.579485-1783294029
:GNOME_KEYRING_CONTROL=/tmp/keyring-Ce50B4
:USER=chris
:GLADE_MODULE_PATH=:
:SSH_AUTH_SOCK=/tmp/ssh-cbCnytpF1179/agent.1179
:USERNAME=chris
:NEWSPEC_MIN_RPMVER=4.4
:XDG_CONFIG_DIRS=/etc/xdg
:MAIL=/var/spool/mail/chris
:DESKTOP_SESSION=xfce
:PATH=/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/home/chris/.bin
:PWD=/home/chris
:EDITOR=nano
:KDE_IS_PRELINKED=1
:LANG=de_DE.UTF-8
:GNOME_KEYRING_PID=1177
:KDEDIRS=/usr
:GDMSESSION=xfce
:SSH_ASKPASS=/usr/libexec/openssh/gnome-ssh-askpass
:HISTCONTROL=ignoredups
:T610=00:0F:DE:1C:B4:DD
:SHLVL=2
:HOME=/home/chris
:XDG_SEAT=seat0
:LOGNAME=chris
:CVS_RSH=ssh
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-WDcrnTXryj,guid=b15401cd9481ec7c231fe6870000002d
:XDG_DATA_DIRS=/usr/local/share:/usr/share
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:XDG_RUNTIME_DIR=/run/user/chris
:GLADE_CATALOG_PATH=:
:LIBGLADE_MODULE_PATH=:
:NEWSPEC_PREFER_MACROS=1
:N97=D8:75:33:B8:52:4E
:XAUTHORITY=/var/run/gdm/auth-for-chris-ilvooq/database
:_=/usr/bin/xfce4-session
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1234,unix/unix:/tmp/.ICE-unix/1234
:DISPLAY=:0.0

smolt_data:
:
:
:Allgemein
:=================================
:UUID: ad5ae965-f0b4-42a7-bf52-d388ace53883
:OS: Fedora release 17 (Beefy Miracle)
:Standard-Runlevel: Unknown
:Sprache: de_DE.UTF-8
:Plattform: x86_64
:BogoMIPS: 4787.83
:CPU-Anbieter: GenuineIntel
:CPU-Modell: Intel(R) Core(TM) i5 CPU       M 520  @ 2.40GHz
:CPU-Stepping: 5
:CPU Familie: 6
:CPU-Modellnummer: 37
:Anzahl der CPUs: 4
:CPU-Geschwindigkeit: 2400
:Systemspeicher: 3753
:System-Swap: 8191
:Anbieter: LENOVO
:System: 3323RJG ThinkPad X201
:Form-Faktor: Notebook
:Kernel: 3.3.0-1.fc17.x86_64
:SELinux aktiviert: 1
:SELinux-Richtlinie: targeted
:SELinux erzwingen: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Geräte
:=================================
:(32902:11362:6058:8598) pci, None, HOST/PCI, Core Processor QuickPath Architecture Generic Non-core Registers
:(32902:11521:6058:8598) pci, None, HOST/PCI, Core Processor QuickPath Architecture System Address Decoder
:(32902:68:6058:8595) pci, agpgart-intel, HOST/PCI, Core Processor DRAM Controller
:(32902:11536:6058:8598) pci, None, HOST/PCI, Core Processor QPI Link 0
:(32902:11537:6058:8598) pci, None, HOST/PCI, Core Processor QPI Physical 0
:(32902:11538:6058:8598) pci, None, HOST/PCI, Core Processor Reserved
:(32902:11539:6058:8598) pci, None, HOST/PCI, Core Processor Reserved
:(32902:15152:6058:8551) pci, i801_smbus, SERIAL, 5 Series/3400 Series Chipset SMBus Controller
:(32902:15151:6058:8552) pci, ahci, STORAGE, 5 Series/3400 Series Chipset 6 port SATA AHCI Controller
:(32902:15111:6058:8550) pci, None, PCI/ISA, Mobile 5 Series Chipset LPC Interface Controller
:(32902:15154:6058:8592) pci, intel ips, NONE, 5 Series/3400 Series Chipset Thermal Subsystem
:(32902:4330:6058:8531) pci, e1000e, ETHERNET, 82577LM Gigabit Network Connection
:(32902:9288:6058:8549) pci, None, PCI/PCI, 82801 Mobile PCI Bridge
:(32902:15164:6058:8547) pci, ehci_hcd, USB, 5 Series/3400 Series Chipset USB2 Enhanced Host Controller
:(32902:15156:6058:8547) pci, ehci_hcd, USB, 5 Series/3400 Series Chipset USB2 Enhanced Host Controller
:(32902:15204:6058:8543) pci, None, SIMPLE, 5 Series/3400 Series Chipset HECI Controller
:(32902:70:6058:8538) pci, i915, VIDEO, Core Processor Integrated Graphics Controller
:(32902:15176:6058:8548) pci, pcieport, PCI/PCI, 5 Series/3400 Series Chipset PCI Express Root Port 4
:(32902:15170:6058:8548) pci, pcieport, PCI/PCI, 5 Series/3400 Series Chipset PCI Express Root Port 1
:(32902:15178:6058:8548) pci, pcieport, PCI/PCI, 5 Series/3400 Series Chipset PCI Express Root Port 5
:(32902:15190:6058:8542) pci, snd_hda_intel, MULTIMEDIA, 5 Series/3400 Series Chipset High Definition Audio
:(32902:15207:6058:8546) pci, serial, 16550_SERIAL, 5 Series/3400 Series Chipset KT Controller
:(32902:16952:32902:4369) pci, iwlwifi, NETWORK, Centrino Ultimate-N 6300 3x3 AGN
:
:
:Dateisysteminformationen
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/vg_01-lv_root / ext4 4096 4096 7855238 6605008 6526378 1966080 1830254 1830254
:/dev/sda1 /boot ext4 1024 1024 508745 433595 407995 128016 127781 127781
:/dev/mapper/luks-a2c0d30c-90ba-42a8-aa81-02fce2acb7e8 /home ext4 4096 4096 60295141 6776605 3758288 15097856 14300697 14300697
:

var_log_messages:
:Mar 24 17:46:29 thinkmatic kernel: [14287.417578] xfce4-power-man[15533] general protection ip:40dd4f sp:7fff563fbbb0 error:0 in xfce4-power-manager[400000+24000]
:Mar 24 17:46:29 thinkmatic abrt[18300]: Saved core dump of pid 15533 (/usr/bin/xfce4-power-manager) to /var/spool/abrt/ccpp-2012-03-24-17:46:29-15533 (12283904 bytes)
Comment 1 Christoph Wickert 2012-03-25 06:07:35 EDT
Created attachment 572503 [details]
File: dso_list
Comment 2 Christoph Wickert 2012-03-25 06:09:06 EDT
Created attachment 572504 [details]
File: coredump
Comment 3 Christoph Wickert 2012-03-25 06:09:12 EDT
Created attachment 572505 [details]
File: maps
Comment 4 Christoph Wickert 2012-03-25 06:09:15 EDT
Created attachment 572506 [details]
File: backtrace
Comment 5 Christoph Wickert 2012-03-25 06:27:39 EDT
*** Bug 805528 has been marked as a duplicate of this bug. ***
Comment 6 abrt-bot 2012-03-30 08:18:02 EDT
*** Bug 751121 has been marked as a duplicate of this bug. ***
Comment 7 Matthias Runge 2012-06-04 02:40:20 EDT
Haven't seen this for a longer time now. Bug can be closed, right?
Comment 8 Christoph Wickert 2012-06-04 03:59:03 EDT
I think so. I was the one who filed the bug and I haven't seen it ever again. And it seems it was not even caused by xfce4-power-manager because the bug disappeared without an update.
Comment 9 z117 2012-06-28 22:27:50 EDT
Still have it on each suspend/resume cycle and power cord unplug.
Comment 10 z117 2012-06-29 12:34:47 EDT
Looks like it is locale-dependent. Always got it with LANG=ru_RU.utf8, and no crash with LANG=C. I've traced it down to
(gdb) 
xfpm_battery_get_message_from_battery_state (battery=0x80c5800)
    at xfpm-battery.c:242
242				msg = g_strdup_printf (_("%s (%i%%)\nEstimated time left is %s."), tmp, battery->priv->percentage, est_time_str);
(gdb) print tmp
$3 = (gchar *) 
    0x8116c00 "Система работает от: батарея "
(gdb) print est_time_string
No symbol "est_time_string" in current context.
(gdb) print est_time_str
$4 = (gchar *) 0x8140ec0 "3 часа 1 минута"
(gdb) n

Program received signal SIGSEGV, Segmentation fault.
0x4b96aa6c in _IO_vfprintf_internal (s=s@entry=0xbfffecc0, 
    format=<optimized out>, format@entry=
    0xb7ca2ad1 "%s\nУстройство (%s) разряжается (%i%%)\nОставшееся время работы около %s.", ap=
    0xbfffee0c "\300\016\024\b\370\267\006\b", ap@entry=0xbfffee04 "")
    at vfprintf.c:1570
1570		  process_string_arg (((struct printf_spec *) NULL));
(gdb) q

Note You need to log in before you can comment on or make changes to this bug.