Bug 806624 - config dynlinked against older xmonad version breaks when version is updated
config dynlinked against older xmonad version breaks when version is updated
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xmonad (Show other bugs)
16
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Jens Petersen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-25 09:46 EDT by Erik Streb del Toro
Modified: 2012-06-13 17:31 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-09 21:27:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Erik Streb del Toro 2012-03-25 09:46:14 EDT
Description of problem:
I can’t start xmonad since an update some weeks ago.

Version-Release number of selected component (if applicable):
xmonad-core-0.10-3.fc16.4.x86_64.rpm

How reproducible:
I enter “xmonad” in a terminal.

  
Actual results:
I get an error message:
/home/erik/.xmonad/xmonad-x86_64-linux: error while loading shared libraries: libHSxmonad-contrib-0.9.2-ghc7.0.4.so: cannot open shared object file: No such file or directory


Expected results:
No error, just start xmonad.

Additional info:
I don’t know how to workaround this problem, but I need my machine, so for me it is urgent.

PS: I will try the Fedora 17 alpha live system, if it has the same problem. And then report back.
Comment 1 Erik Streb del Toro 2012-03-25 09:47:58 EDT
Additional info:
A file called /usr/lib64/ghc-7.0.4/xmonad-contrib-0.10/libHSxmonad-contrib-0.10-ghc7.0.4.so exists, so I don’t know why xmonad complains and how this got broken. No manual changes to the system.
Comment 2 Jens Petersen 2012-04-04 04:49:21 EDT
Sorry you need to recompile your xmonad config for the version change.

The easiest way to do that is 

$ xmonad --recompile

which forces a recompilation.  That should fix your issue.

This kind of problem is the reason why I reverted the Fedora
specific patch to xmonad to use dynamic instead of static linking.

If we get to do this again we'd need to think about how to handle
this problem in the future, but perhaps I should think about a
workaround for your upgrade case.
Comment 3 Erik Streb del Toro 2012-04-04 11:19:09 EDT
(In reply to comment #2)
> Sorry you need to recompile your xmonad config for the version change.
> 
> The easiest way to do that is 
> 
> $ xmonad --recompile
> 
> which forces a recompilation.  That should fix your issue.

Thank you very much. That fixed it.

> If we get to do this again we'd need to think about how to handle
> this problem in the future, but perhaps I should think about a
> workaround for your upgrade case.

Why not put a recompile command in the post of the rpm-update-package?
Comment 4 Ben Boeckel 2012-04-04 11:25:23 EDT
(In reply to comment #3)
> Why not put a recompile command in the post of the rpm-update-package?

We'd have to run it per user that runs xmonad.
Comment 5 Jens Petersen 2012-04-09 02:31:27 EDT
> > Why not put a recompile command in the post of the rpm-update-package?
> 
> We'd have to run it per user that runs xmonad.

Right - perhaps it could be done in xmonad-start,
though it could be a little messy.
Comment 6 Jens Petersen 2012-05-24 02:59:52 EDT
I have added a fix in xmonad-0.10-7.fc18 such that xmonad-start
(which normally starts xmonad in Fedora) will try to check if
a user's custom binary has broken shared libs and if so touch
xmonad.hs to force recompiling at startup.

A test upgrade to pre-release F17 made me realise that this issue
also affects people upgrading to F17 because of the gmp soname bump.
I plan to backport the fix to F16 and F17 shortly.
Comment 7 Fedora Update System 2012-05-24 08:01:43 EDT
xmonad-0.10-8.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/xmonad-0.10-8.fc17
Comment 8 Fedora Update System 2012-05-25 01:41:37 EDT
xmonad-0.10-3.5.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/xmonad-0.10-3.5.fc16
Comment 9 Fedora Update System 2012-05-26 03:54:41 EDT
Package xmonad-0.10-9.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xmonad-0.10-9.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-8438/xmonad-0.10-9.fc17
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2012-06-09 21:27:15 EDT
xmonad-0.10-11.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2012-06-13 17:31:19 EDT
xmonad-0.10-3.7.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.