Bug 806626 - reboot after install hangs indefinitely
reboot after install hangs indefinitely
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.2
Unspecified Unspecified
high Severity high
: beta
: 6.3
Assigned To: Fabian Deutsch
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-25 09:49 EDT by Mike Burns
Modified: 2016-04-26 11:06 EDT (History)
11 users (show)

See Also:
Fixed In Version: ovirt-node-2.3.0-3.el6
Doc Type: Bug Fix
Doc Text:
Previously, the reboot that occurs during the installation process would not not complete successfully, requiring the user to manually reboot the system. Now, the automatic reboot during the installation process will work correctly.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-19 10:19:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Burns 2012-03-25 09:49:59 EDT
Description of problem:
After performing a TUI installation, the reboot step never completes, ctrl-alt-del doesn't do anything.

This requires a manual power cycle.

Version-Release number of selected component (if applicable):
6.3

How reproducible:
twice in 2 tries

Steps to Reproduce:
1.install via tui
2.
3.
  
Actual results:
Reboot hangs

Expected results:
Reboot works correctly

Additional info:
Installation appears to be fine, power cycle brings machine up running correctly.
Comment 1 Fabian Deutsch 2012-03-30 11:10:36 EDT
This only appears during installation.
When selecting reboot on an installed system it works fine.

To reboot after an installation the following procdeure can be used:
- F2, Drop to emergency shell
- kill ovirt-config-install
- $ reboot
Comment 3 Mike Burns 2012-03-30 17:10:13 EDT
Patch does not solve reboot after an install.  Both auto-install and TUI install hang when getting to the reboot step.

Workaround:  everything is complete except the reboot, so forcing the machine to reboot via a managment card (drac, ilo, rsa, imm, etc) will work.  Also, a power cycle of the machine should work as well.
Comment 5 Fabian Deutsch 2012-04-05 13:43:38 EDT
Please review the following patch which should solve the problem after an auto-install.

http://gerrit.virt.bos.redhat.com:8080/gerrit/#change,130
Comment 8 Mike Burns 2012-06-13 12:56:31 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Previously, a reboot would hang forever in certain circumstances during the install process.  Now, reboot will function correctly and the installation completes.
Comment 9 Stephen Gordon 2012-06-13 15:49:10 EDT
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1 +1 @@
-Previously, a reboot would hang forever in certain circumstances during the install process.  Now, reboot will function correctly and the installation completes.+Previously, the reboot that occurs during the installation process would not not complete successfully, requiring the user to manually reboot the system. Now, the automatic reboot during the installation process will work correctly.
Comment 11 errata-xmlrpc 2012-07-19 10:19:51 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0741.html

Note You need to log in before you can comment on or make changes to this bug.