Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 806688 - Missing libtool build dep can lead to strange errors
Summary: Missing libtool build dep can lead to strange errors
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gforth
Version: 16
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Adrian Reber
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-03-26 01:04 UTC by Rick Elrod
Modified: 2012-04-05 20:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-04-05 20:12:26 UTC
Type: ---


Attachments (Terms of Use)
Added the missing builddep to the gforth spec file. (369 bytes, patch)
2012-03-26 01:04 UTC, Rick Elrod
no flags Details | Diff

Description Rick Elrod 2012-03-26 01:04:03 UTC
Created attachment 572607 [details]
Added the missing builddep to the gforth spec file.

Description of problem:

Version-Release number of selected component (if applicable):
gforth-0.7.0-5.fc16


How reproducible:
Always


Steps to Reproduce:
1. Run gforth
2. Type: require unix/socket.fs hostname type
  

Actual results:
*without* libtool build dep:

[ricky@laptop ~]$ gforth
Gforth 0.7.0, Copyright (C) 1995-2008 Free Software Foundation, Inc.
Gforth comes with ABSOLUTELY NO WARRANTY; for details type `license'
Type `bye' to exit
require unix/socket.fs hostname type sh: --silent: command not found

/usr/share/gforth/0.7.0/unix/socket.fs:48: libtool compile failed
>>>end-c-library<<<
Backtrace:
$7FB80715C988 throw 
$7FB807198458 c(abort") 
$7FB807199050 compile-wrapper-function1 


Expected results:
*with* libtool build dep:

[ricky@laptop rpmbuild]$ gforth
Gforth 0.7.0, Copyright (C) 1995-2008 Free Software Foundation, Inc.
Gforth comes with ABSOLUTELY NO WARRANTY; for details type `license'
Type `bye' to exit
require unix/socket.fs hostname type
laptop.home.elrod.me ok


Additional info:

Comment 1 Adrian Reber 2012-03-26 13:13:45 UTC
Thanks for the report. Should have been fixed in gforth-0.7.0-7.fc18 but it fails (probably due to the newer gcc). But hopefully fixed soon.

Comment 2 Adrian Reber 2012-04-05 20:12:26 UTC
Fixed in gforth-0.7.0-8.fc18. For now building with -O0.


Note You need to log in before you can comment on or make changes to this bug.