Bug 806703 - Found a few typos...
Found a few typos...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: doc-Identity_Management_Guide (Show other bugs)
6.2
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Deon Ballard
ecs-bugs
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-25 23:15 EDT by Morgan Weetman
Modified: 2014-01-10 00:43 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-26 19:22:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Morgan Weetman 2012-03-25 23:15:06 EDT
URL: https://docs.fedoraproject.org/en-US/Fedora/16/html/FreeIPA_Guide/


#> Example command has an extra dash in front of '-r'
-----------------------------------------------------------------------------
Example 2.1. Basic Installation without Interaction

# ipa-server-install -a secret12 --hostname=ipaserver.example.com --r EXAMPLE.COM -p secret12 -n example.com -U
-----------------------------------------------------------------------------


#> Example command doesn't match the text in regard to using a comma separated list
-----------------------------------------------------------------------------
Example 2.5. Setting up DNS Non-Interactively
To use DNS always requires the --setup-dns. To user forwarders, use the --forwarder with a comma-separated list of forwarders.

# ipa-server-install ... --setup-dns --forwarder=1.2.3.0 --forwarder=1.2.255.0
-----------------------------------------------------------------------------


#> Poor grammar in title plus missing/strange content
-----------------------------------------------------------------------------
2.6. Upgrading from FreeIPA from 6.2 to 6.3
i 
-----------------------------------------------------------------------------


#> Typo: replace 'it' with 'is'
-----------------------------------------------------------------------------
4.1.2.2. Page Elements
...
When a task like adding an entry or saving a change is possible, the task link it blue.
-----------------------------------------------------------------------------


#> Typo: replace 'suer' with 'user'
-----------------------------------------------------------------------------
5.3. Managing Public SSH Keys for Users
...
On Fedora, the System Security Services Daemon (SSSD) can be configured to cache and retrieve user SSH keys so that applications and services only have to look in one location for suer keys.
-----------------------------------------------------------------------------


#> Broken link: http://docs.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/6-Beta/html/Deployment_Guide/openssh-sssd.html
-----------------------------------------------------------------------------
5.3. Managing Public SSH Keys for Users
...
After uploading the user keys, configure SSSD to use FreeIPA as one of its identity domains and set up OpenSSH to use the SSSD tooling for managing user keys. This is covered in the Fedora Deployment Guide. 
-----------------------------------------------------------------------------


#> Typo: missing word - '... even if it (is) not unique'
-----------------------------------------------------------------------------
5.8.1.1. With the Web UI
...
Setting a GID number is not necessary because of the risk of collisions. If a GID number is given manually, FreeIPA will not override the specified GID number, even if it not unique.
-----------------------------------------------------------------------------


#> Typo: missing 'd' in deleted, lowercase 'i' in 'if'

6.5.1. Adding and Editing Service Entries and Keytabs
-----------------------------------------------------------------------------
...
This keytab is used for the web UI. if a key were stored in ipa.keytab and that keytab file is delete, ...
-----------------------------------------------------------------------------
Comment 3 Deon Ballard 2012-03-30 15:32:06 EDT
If these are all the typos I have (so far), I really count myself lucky.

Thanks!
Comment 5 Morgan Weetman 2012-04-10 19:13:10 EDT
(In reply to comment #3)
> If these are all the typos I have (so far), I really count myself lucky.
> 
> Thanks!

Just a couple more ...



#> incorrect word used - possibly replace second 'port' with 'above' or 'below'?
-----------------------------------------------------------------------
7.2. Setting the NIS Port for FreeIPA
...
Any available port number port 1024 can be used for the NIS Plug-in setting.
-----------------------------------------------------------------------


#> Extra word - remove one 'attribute' after 'cn'
-----------------------------------------------------------------------
8.1.3.1. Values for cn Attributes
...
One other important difference is that Active Directory uses the cn attribute attribute as its naming
attribute, where FreeIPA uses uid.
-----------------------------------------------------------------------


#> missing content - no reference or instructions on importing the FreeIPA CA cert into AD
#> see step 5 in 8.4.2 for similar content
-----------------------------------------------------------------------
8.3. Managing Synchronization Agreements
...
This means that the Active Directory CA
certificate needs to be imported into the FreeIPA database, and the FreeIPA CA certificate needs to be
imported into the Active Directory database.
-----------------------------------------------------------------------

#> missing word - pg 206
-----------------------------------------------------------------------
10.4.1. Setting up Samba Groups in FreeIPA
FreeIPA is not configured to create Samba groups by default. It is possible to change the FreeIPA
configuration so that groups are automatically <word_missing_here> as Samba groups that work with the CIFS server.
-----------------------------------------------------------------------


#> Table entry doubled - 'Max lifetime' pg 222
-----------------------------------------------------------------------
Table 11.2. Default Global Password Policy
Attribute Value
Max lifetime 90
Max lifetime 90 (days)
Min lifetime 1 (hour)
-----------------------------------------------------------------------


#> typo - 'ro' instead of 'or' pg 241
-----------------------------------------------------------------------
13.1. About sudo and IPA
The sudo command allows a system administrator to delegate authority to specific users to run
specific commands as root ro another specified user. 
-----------------------------------------------------------------------


#> typo - 's' on 'rules' pg 275
-----------------------------------------------------------------------
Example 14.5. Testing a Specific Rule
It is possible to check a specific rules (or several rules).
-----------------------------------------------------------------------


#> typo - 'service' should be 'services' pg 326
-----------------------------------------------------------------------
18.4.1. Using an OSCP Responder with SELinux
Clients can use the FreeIPA OCSP responder to check certificate validity or to retrieve CRLs. A client
can be a number of different service, but is most frequently an Apache server and the mod_revocator
module (which handles CRL and OCSP operations).
-----------------------------------------------------------------------


#> typo - 'featurea' instead of 'features' pg 336
-----------------------------------------------------------------------
19.1.1.2. Recommended Configuration for Fedora Clients
...
very closely with FreeIPA and leverage the full authentication and identity featurea in FreeIPA.
-----------------------------------------------------------------------


#> typo ? - 'Fedora' instead of 'RHEL' pg 337
-----------------------------------------------------------------------
19.1.1.3. Alternative Supported Configuration
...
Likewise, older Fedora versions (6.1 and 5.6)
support SSSD but have an older version, which does not support FreeIPA as an identity provider.
-----------------------------------------------------------------------


#> typo - 'coverts' instead of 'converts' pg 344
-----------------------------------------------------------------------
Once the information is exported, the script adds all required FreeIPA object classes and attributes
and coverts DNs in attributes to match the FreeIPA directory tree.
-----------------------------------------------------------------------


#> typo - missing word (commands)? pg 351
-----------------------------------------------------------------------
B.2.3. Help Topics
All of the ipa <missing_word> are loosely organized in groups, based on the configuration area that they relate to.
-----------------------------------------------------------------------
Comment 9 John Skeoch 2012-06-24 19:45:31 EDT
Verified in:

http://docs.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/6/html/Identity_Management_Guide/Migrating_from_a_Directory_Server_to_IPA-Performing_a_Server_based_Migration.html

Red_Hat_Enterprise_Linux-Identity_Management_Guide-6-en-US-2.2.0-0.9

---

Once the information is exported, the script adds all required IPA object classes and attributes and converts DNs in attributes to match the IPA directory tree.

Note You need to log in before you can comment on or make changes to this bug.