Bug 806801 - UI should raise appropriate msg when promotion fails for the repo for which sync is in-progress
UI should raise appropriate msg when promotion fails for the repo for which s...
Status: CLOSED WORKSFORME
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.1
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Brad Buckingham
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-26 05:32 EDT by Sachin Ghai
Modified: 2013-08-16 14:15 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-29 07:30:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
raised error while promoting the product (74.24 KB, image/png)
2012-03-26 05:34 EDT, Sachin Ghai
no flags Details
Katello-debus logs (572.80 KB, application/x-gzip)
2012-03-26 05:36 EDT, Sachin Ghai
no flags Details
UI raised proper message (31.49 KB, image/png)
2012-03-29 07:29 EDT, Sachin Ghai
no flags Details

  None (edit)
Description Sachin Ghai 2012-03-26 05:32:51 EDT
Description of problem:
I was trying to verify bz 799122 and added the repo to changeset for which sync was on going. When I promote the product from UI, UI raised following error:

Failed to promote: Missing partial changesets/warning with {:locale=>[:en, :en], :handlers=>[:builder, :haml, :rjs, :rhtml, :rxml, :erb], :formats=>[:html, :text, :js, :css, :ics, :csv, :xml, :rss, :atom, :yaml, :multipart_form, :url_encoded_form, :json, :svg, :tdl, :pdf]} in view paths "/usr/share/katello/app/views"

No error found in production.log and then I manually set the log level to 'debug' and production.log generate following logs in production.log


[root@scroponok ~]# tail -f /var/log/katello/production.log 
[ INFO: 2012-03-26 14:57:47 #390]   Parameters: {"id"=>"3"}
[DEBUG: 2012-03-26 14:57:47 #390] Setting locale: en
[DEBUG: 2012-03-26 14:57:47 #390] Setting current user thread-local variable to admin
[DEBUG: 2012-03-26 14:57:47 #390] Checking  params  for changesets/promote
[DEBUG: 2012-03-26 14:57:47 #390] Authorizing admin for changesets/promote
[DEBUG: 2012-03-26 14:57:47 #390] Resource GET request: /pulp/api/repositories/ACME_Corporation-rhel62-rhel62_64/sync/
[DEBUG: 2012-03-26 14:57:48 #390] Processing response: 200
[ INFO: 2012-03-26 14:57:48 #390] Rendered text template (0.0ms)
[DEBUG: 2012-03-26 14:57:48 #390] Setting current user thread-local variable to nil
[ INFO: 2012-03-26 14:57:48 #390] Completed 500 Internal Server Error in 885ms (Views: 10.8ms | ActiveRecord: 134.2ms)


Version-Release number of selected component (if applicable):
python-isodate-0.4.4-4.pulp.el6.noarch
pulp-1.0.0-6.el6.noarch
katello-0.1.306-1.el6.noarch
mod_wsgi-3.3-3.pulp.el6.x86_64
katello-glue-candlepin-0.1.306-1.el6.noarch
pulp-common-1.0.0-6.el6.noarch
m2crypto-0.21.1.pulp-7.el6.x86_64
candlepin-0.5.26-1.el6.noarch
pulp-selinux-server-1.0.0-6.el6.noarch
katello-glue-pulp-0.1.306-1.el6.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
python-oauth2-1.5.170-2.pulp.el6.noarch
candlepin-tomcat6-0.5.26-1.el6.noarch
katello-cli-0.1.107-1.el6.noarch

How reproducible:
always

Steps to Reproduce:
1. Create a provider/product/repo
2. sync the repo
3. Promote the product while sync is in-progress
  
Actual results:
Failed to promote: Missing partial changesets/warning with {:locale=>[:en, :en], :handlers=>[:builder, :haml, :rjs, :rhtml, :rxml, :erb], :formats=>[:html, :text, :js, :css, :ics, :csv, :xml, :rss, :atom, :yaml, :multipart_form, :url_encoded_form, :json, :svg, :tdl, :pdf]} in view paths "/usr/share/katello/app/views"


Expected results:
UI should raise appropriate warning message like: 'The sync is in-progress for the selected product"

Additional info:
Comment 1 Sachin Ghai 2012-03-26 05:34:05 EDT
Created attachment 572720 [details]
raised error while promoting the  product
Comment 2 Sachin Ghai 2012-03-26 05:36:03 EDT
Created attachment 572721 [details]
Katello-debus logs
Comment 3 Sachin Ghai 2012-03-29 07:29:00 EDT
Verified with following CFSE build:

pulp-1.0.0-8.el6.noarch
katello-0.1.307-1.el6.noarch
katello-cli-0.1.107-1.el6.noarch

Now UI is raising proper warning message while trying the promotion for the repo which is being synced. Please see the attachment.
Comment 4 Sachin Ghai 2012-03-29 07:29:43 EDT
Created attachment 573639 [details]
UI raised proper message
Comment 5 Mike McCune 2013-08-16 14:15:45 EDT
getting rid of 6.0.0 version since that doesn't exist

Note You need to log in before you can comment on or make changes to this bug.