Bug 806817 - meets "already reached the application limit of 5" when trying to create the 5th app
meets "already reached the application limit of 5" when trying to create the ...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Pod (Show other bugs)
1.x
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Rajat Chopra
libra bugs
: Regression, Triaged
: 806989 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-26 05:54 EDT by Meng Bo
Modified: 2012-04-13 14:31 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-13 14:31:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Meng Bo 2012-03-26 05:54:48 EDT
Description of problem:
user domain has four apps on it, and when trying to create the 5th app, will get the "already reached the application limit of 5" error.

Version-Release number of selected component (if applicable):
rhc-devenv-0.89.1-1.git.215.ed37f99.el6.noarch

How reproducible:
always

Steps to Reproduce:
1.create domain
2.create four apps on this domain
3.create the 5th app
  
Actual results:
meets "already reached the application limit of 5" error, and the app cannot be created successful.

Expected results:
5th app should be created successfully

Additional info:
server log:

Started POST "/broker/userinfo" for 66.187.233.202 at Mon Mar 26 05:48:53 -0400 2012
  Processing by LegacyBrokerController#user_info_post as 
  Parameters: {"json_data"=>"{\"api\":\"1.1.3\",\"rhlogin\":\"bmeng@redhat.com\"}", "password"=>"[FILTERED]"}
User-Agent = ''
Adding user bmeng@redhat.com...inside login
MongoDataStore.find(CloudUser, bmeng@redhat.com, bmeng@redhat.com)

MongoDataStore.find(CloudUser, bmeng@redhat.com, bmeng@redhat.com)

Completed 200 OK in 279ms (Views: 4.6ms)


Started POST "/broker/ssh_keys" for 66.187.233.202 at Mon Mar 26 05:48:59 -0400 2012
  Processing by LegacyBrokerController#ssh_keys_post as 
  Parameters: {"json_data"=>"{\"api\":\"1.1.3\",\"action\":\"list-keys\",\"rhlogin\":\"bmeng@redhat.com\"}", "password"=>"[FILTERED]"}
User-Agent = ''
Adding user bmeng@redhat.com...inside login
MongoDataStore.find(CloudUser, bmeng@redhat.com, bmeng@redhat.com)

MongoDataStore.find(CloudUser, bmeng@redhat.com, bmeng@redhat.com)

Completed 200 OK in 112ms (Views: 1.9ms)
Comment 2 Rajat Chopra 2012-03-26 17:19:29 EDT
fixed with rev#26554ee9f242b9af95c02c93a5f65bc70d6a9c41
Comment 3 Meng Bo 2012-03-27 04:38:31 EDT
checked on devenv_1674,
bug has been fixed.
Comment 4 Rajat Chopra 2012-03-27 16:34:51 EDT
*** Bug 806989 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.