Bug 806822 - dracut-017-59.git20120321.fc17 breaks f16->f17 upgrades through yum
dracut-017-59.git20120321.fc17 breaks f16->f17 upgrades through yum
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dracut (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: dracut-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 806860
  Show dependency treegraph
 
Reported: 2012-03-26 05:58 EDT by Christophe Fergeau
Modified: 2012-03-31 20:28 EDT (History)
3 users (show)

See Also:
Fixed In Version: dracut-013-22.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 806860 (view as bug list)
Environment:
Last Closed: 2012-03-31 20:28:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christophe Fergeau 2012-03-26 05:58:24 EDT
Description of problem:

dracut-017-59.git20120321.fc17 added a require on util-linux >= 2.21 which is only in f16.
Trying to follow https://fedoraproject.org/wiki/Upgrading_Fedora_using_yum#Fedora_16_-.3E_Fedora_17 causes util-linux to be upgraded at the "yum --releasever=17 update rpm dracut" step, which ends up trying
to upgrade filesystem to the f17 version. This package cannot be installed at this point since the goal of the first step is to do the usrbin conversion, and f17 filesystem package cannot be installed before the conversion is done.
Comment 1 Fedora Update System 2012-03-26 07:22:59 EDT
dracut-013-22.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/dracut-013-22.fc16
Comment 2 Fedora Update System 2012-03-30 23:27:56 EDT
Package dracut-013-22.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dracut-013-22.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-5109/dracut-013-22.fc16
then log in and leave karma (feedback).
Comment 3 Fedora Update System 2012-03-31 20:28:20 EDT
dracut-013-22.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.