Bug 806823 - [RFE] make "continue" is selected by default on the device selection window
[RFE] make "continue" is selected by default on the device selection window
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.3
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: Joey Boggs
Virtualization Bugs
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-26 06:01 EDT by Guohua Ouyang
Modified: 2016-04-26 10:10 EDT (History)
12 users (show)

See Also:
Fixed In Version: ovirt-node-2.3.0-2.el6
Doc Type: Enhancement
Doc Text:
Previously, when selecting the root disk for installation, the user would need to highlight the disk, then navigate to the Continue button. Now, hitting Enter once the desired device is selected will have the same effect, moving the user forward to the next screen.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-19 10:20:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Guohua Ouyang 2012-03-26 06:01:05 EDT
Description of problem:
Currently, on the device selection window during TUI installation, the continue button is not selected by default, can not go to next window by press "Enter".
Default enable the "continue" button on the device selection window will be more convenient to install RHEV-H.

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.3-20120307.2

How reproducible:
100%

Steps to Reproduce:
1.
 
Actual results:

Expected results:


Additional info:
Comment 2 Joey Boggs 2012-03-26 16:24:54 EDT
can do this a few ways
- make the continue button first in the order(least invasive)
- make enter on the device box goto the next page

Just can't make continue the first one highlighted in the current spot this will reorder how the buttons determine their order as they are placed on the form for the screen
Comment 3 Mike Burns 2012-03-26 17:04:06 EDT
(In reply to comment #2)
> can do this a few ways
> - make the continue button first in the order(least invasive)
> - make enter on the device box goto the next page
> 
> Just can't make continue the first one highlighted in the current spot this
> will reorder how the buttons determine their order as they are placed on the
> form for the screen


We should make it enter activated.  If you think it's too invasive, let's defer this and fix it upstream and then include it in the next release.

The keyboard layout page does this already.  I like having the continue button there as well.  

One thing to note:

This should only be done on the Root disk selection page.  Not on the HostVG disk selection page since that is a multi-select page.
Comment 7 Guohua Ouyang 2012-04-16 04:15:54 EDT
Verified on 6.3-20120411.1, enter is activated on the Root disk selection page.
Comment 8 Mike Burns 2012-06-13 13:38:09 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Previously, when selecting the Root disk for installation, an admin would need to highlight the disk, then navigate to the Continue button.  Now, hitting Enter on the desired device will have the same effect of moving forward to the next screen.
Comment 9 Stephen Gordon 2012-06-14 11:27:18 EDT
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1 +1 @@
-Previously, when selecting the Root disk for installation, an admin would need to highlight the disk, then navigate to the Continue button.  Now, hitting Enter on the desired device will have the same effect of moving forward to the next screen.+Previously, when selecting the root disk for installation, an admin would need to highlight the disk, then navigate to the Continue button. Now, hitting Enter once the desired device is selected will have the same effect, moving the user forward to the next screen.
Comment 10 Stephen Gordon 2012-06-14 11:27:34 EDT
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1 +1 @@
-Previously, when selecting the root disk for installation, an admin would need to highlight the disk, then navigate to the Continue button. Now, hitting Enter once the desired device is selected will have the same effect, moving the user forward to the next screen.+Previously, when selecting the root disk for installation, the user would need to highlight the disk, then navigate to the Continue button. Now, hitting Enter once the desired device is selected will have the same effect, moving the user forward to the next screen.
Comment 12 errata-xmlrpc 2012-07-19 10:20:02 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0741.html

Note You need to log in before you can comment on or make changes to this bug.