Bug 806837 - oVirt-Engine-Installer - Installation process fails when configuring remoteDB without super-user privileges
oVirt-Engine-Installer - Installation process fails when configuring remoteD...
Status: CLOSED INSUFFICIENT_DATA
Product: oVirt
Classification: Community
Component: ovirt-engine-installer (Show other bugs)
unspecified
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Ofer Schreiber
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-26 06:38 EDT by Ortal
Modified: 2012-04-15 07:19 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-15 07:19:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine-setup.log (15.86 KB, text/plain)
2012-03-26 06:41 EDT, Ortal
no flags Details

  None (edit)
Description Ortal 2012-03-26 06:38:27 EDT
Description of problem:

oVirt-Engine-Installer -  Installation process fails when configuring remoteDB without super-user privileges 

Version-Release number of selected component (if applicable):
ovirt-engine-setup-3.1.0_0001-3.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Ensure remoteDB configured without super-user privileges
2. Run ovirt-engine-setup utility
  
Actual results:

Installation process failed due the fact that remoteDB doesn't have super-user privileges:

2012-03-26 12:39:18::DEBUG::common_utils::308::root:: stderr =
2012-03-26 12:39:18::DEBUG::common_utils::309::root:: retcode = 0
2012-03-26 12:39:24::INFO::engine_validators::111::root:: validating ortal-test as a valid user name
2012-03-26 12:39:28::DEBUG::engine_validators::71::root:: Validating password
2012-03-26 12:39:28::WARNING::engine_validators::77::root:: Password failed check
2012-03-26 12:39:28::WARNING::engine_validators::78::root:: Traceback (most recent call last):
  File "/usr/share/ovirt-engine/scripts/engine_validators.py", line 75, in validatePassword
    cracklib.FascistCheck(param)
ValueError: it is too simplistic/systematic

2012-03-26 12:39:29::DEBUG::engine-setup::552::root:: Param confirmation passed, value for both questions is identical
2012-03-26 12:39:31::INFO::engine_validators::84::root:: Validating no as part of ['yes', 'no']
2012-03-26 12:39:31::INFO::engine_validators::138::root:: Validating 10.35.97.94 as a RemoteDb
2012-03-26 12:39:31::DEBUG::common_utils::258::root:: cmd = /sbin/ip addr
2012-03-26 12:39:31::DEBUG::common_utils::263::root:: output = 1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue state UNKNOWN
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether 00:1a:4a:16:97:1a brd ff:ff:ff:ff:ff:ff
    inet 10.35.97.26/24 brd 10.35.97.255 scope global eth0
    inet6 fe80::21a:4aff:fe16:971a/64 scope link
       valid_lft forever preferred_lft forever

2012-03-26 12:39:31::DEBUG::common_utils::264::root:: stderr =
2012-03-26 12:39:31::DEBUG::common_utils::265::root:: retcode = 0
2012-03-26 12:39:31::DEBUG::common_utils::405::root:: Found IP Address: 10.35.97.26
2012-03-26 12:39:31::DEBUG::engine_validators::336::root:: found existing pgpass file, backing current to /root/.pgpass.2012_03_26_12_39_31 for validation
2012-03-26 12:39:31::INFO::engine_validators::290::root:: Trying to connect to the remote database with provided credentials.
2012-03-26 12:39:31::DEBUG::common_utils::322::root:: running sql query 'select 1' on db server: '10.35.97.94'.
2012-03-26 12:39:31::DEBUG::common_utils::258::root:: cmd = /usr/bin/psql -h 10.35.97.94 -p 5544 -U ortal-test -d postgres -c "select 1"
2012-03-26 12:39:31::DEBUG::common_utils::263::root:: output =
2012-03-26 12:39:31::DEBUG::common_utils::264::root:: stderr = psql: FATAL:  password authentication failed for user "ortal-test"

2012-03-26 12:39:31::DEBUG::common_utils::265::root:: retcode = 2
2012-03-26 12:39:31::ERROR::engine_validators::296::root:: Could not connect to host 10.35.97.94 with provided credentials. Check that your settings are correct.
(END)


Expected results:

Should work with no problems

Additional info:

** Please see attached engine.log
Comment 1 Ortal 2012-03-26 06:41:02 EDT
Created attachment 572728 [details]
engine-setup.log
Comment 2 Ofer Schreiber 2012-03-26 06:48:01 EDT
Ortal,

Can you retest this and attach a "real" failed log?
it's clear from the log you attched that your remote DB isn't configured correctly (psql: FATAL: password authentication failed for user "ortal-test") which means you didn't configured ortal-test as a user in the remote DB

Note You need to log in before you can comment on or make changes to this bug.