Bug 806838 - Caught "ActiveResource::ServerError in ApplicationsController#destroy" error when deleting an application after adding all the cartridges to it.
Caught "ActiveResource::ServerError in ApplicationsController#destroy" error ...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Pod (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Ravi Sankar
libra bugs
: Regression, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-26 06:39 EDT by Yujie Zhang
Modified: 2015-05-14 21:49 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-13 14:34:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yujie Zhang 2012-03-26 06:39:08 EDT
Description of problem:

After adding all the cartridges(except for postsql) to an application,I tried to delete this application,but caught "ActiveResource::ServerError in ApplicationsController#destroy" error.

Version-Release number of selected component (if applicable):

devenv_1672

How reproducible:always


Steps to Reproduce:
1.Go to openshift website and login
2.Create an application and add all the cartridges(except for postsql) to this applciation
3.Try to delete this application
  
Actual results:

Cautht "ActiveResource::ServerError in ApplicationsController#destroy" error when deleting this application,detail error message is as following:

ActiveResource::ServerError in ApplicationsController#destroy

Failed.  Response code = 500.  Response message = Internal Server Error.
Rails.root: /var/www/stickshift/site

Application Trace | Framework Trace | Full Trace
app/controllers/applications_controller.rb:86:in `destroy'
Request

Parameters:

{"utf8"=>"✓",
 "id"=>"app1",
 "_method"=>"delete",
 "authenticity_token"=>"FbD8wljdW0rgjrjrN0UpVijNhonjNJWLz6urQb0kxZ4="}

Expected results:

The application should be deleted without error.

Additional info:
Comment 1 Yujie Zhang 2012-03-26 06:40:01 EDT
This issue did not exist on devenv_1670.
Comment 2 Clayton Coleman 2012-03-26 09:36:25 EDT
500 error from server
Comment 3 Ravi Sankar 2012-03-29 20:36:48 EDT
Can't reproduce the issue on devenv_1679
Comment 4 Xiaoli Tian 2012-03-30 07:31:36 EDT
Verified it on devenv-stage_155,it's fixed now.

Note You need to log in before you can comment on or make changes to this bug.