Bug 806846 - New Image : Upload and URL option does not show any error message when accounts are not mapped to the cloud in which images are being launched
New Image : Upload and URL option does not show any error message when accoun...
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.0.0
Unspecified Unspecified
unspecified Severity high
: 1.0.1
: ---
Assigned To: Jozef Zigmund
wes hayutin
: Triaged, ZStream
: 798510 (view as bug list)
Depends On:
Blocks: 826113
  Show dependency treegraph
 
Reported: 2012-03-26 06:57 EDT by Shveta
Modified: 2012-10-29 10:55 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
There is no error message alerting user to add a provider account before building an image which can cause a user to think that image options are broken. This update provides an alert message to remind user to add a provider account prior to building an image.
Story Points: ---
Clone Of:
: 826113 (view as bug list)
Environment:
Last Closed: 2012-07-10 03:22:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
no provider (205.45 KB, image/png)
2012-03-26 06:57 EDT, Shveta
no flags Details
importing image (205.05 KB, image/png)
2012-03-26 07:06 EDT, Shveta
no flags Details
msg (211.62 KB, image/png)
2012-06-07 00:42 EDT, Aziza Karol
no flags Details

  None (edit)
Description Shveta 2012-03-26 06:57:40 EDT
Created attachment 572733 [details]
no provider

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce: 
1. Clouds -- > Upload or From URL 
2. Browse the template file and continue 
3. The deployable page launched does not show any provider and Build all action 
does not do anything
  
Actual results:


Expected results:


Additional info:

rpm -qa|grep aeolus
aeolus-conductor-0.8.3-1.el6.noarch
aeolus-conductor-daemons-0.8.3-1.el6.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-configure-2.5.2-1.el6.noarch
aeolus-all-0.8.3-1.el6.noarch
rubygem-aeolus-cli-0.3.1-1.el6.noarch
aeolus-conductor-doc-0.8.3-1.el6.noarch
Comment 1 Shveta 2012-03-26 07:05:48 EDT
OK the bug is not that these image options are broken .. They are working fine .
I didnt add accounts to the cloud.

But it didn't give me any message "please add account to the cloud"
as it shows while importing image (attached screenshot)
Comment 2 Shveta 2012-03-26 07:06:24 EDT
Created attachment 572739 [details]
importing image
Comment 3 Hugh Brock 2012-05-08 12:29:41 EDT
We should add an error message that is equivalent to the one we give on image import.
Comment 4 Jozef Zigmund 2012-05-25 09:37:34 EDT
Fix posted to this thread: https://fedorahosted.org/pipermail/aeolus-devel/2012-May/010541.html
Comment 5 Jozef Zigmund 2012-05-25 09:38:44 EDT
Fix pushed to the master branch with commit # dec27f231cacb1ba11e2ddb6f9a2bd77d48c87e4
Comment 6 Jozef Zigmund 2012-05-25 11:12:45 EDT
Fix pushed to the axiom/1.0.1 with commit # 8552fa5732edad7f7b0ae059eb2ba7368f992aeb
Comment 8 sachua 2012-06-05 22:10:05 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
There was no error message alerting user to add a provider account before building an image which can lead to a user thinking that image options are broken. Error message has now been added to remind user to add a provider account prior to building an image.
Comment 9 sachua 2012-06-05 23:41:53 EDT
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1 +1 @@
-There was no error message alerting user to add a provider account before building an image which can lead to a user thinking that image options are broken. Error message has now been added to remind user to add a provider account prior to building an image.+There is no error message alerting user to add a provider account before building an image which can cause a user to think that image options are broken. This update provides an alert message to remind user to add a provider account prior to building an image.
Comment 10 Aziza Karol 2012-06-07 00:39:10 EDT
Error message "images cannot be built, as no provider accounts are currently enabled" is displayed if user tries to build and image before adding a  provider account.

see attache screenshot.


verified on:
rpm -qa | grep aeolus
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-all-0.8.27-1.el6_3.noarch
aeolus-conductor-doc-0.8.27-1.el6_3.noarch
aeolus-conductor-daemons-0.8.27-1.el6_3.noarch
aeolus-conductor-0.8.27-1.el6_3.noarch
aeolus-configure-2.5.7-1.el6_3.noarch
rubygem-aeolus-cli-0.3.3-1.el6_3.noarch
Comment 11 Aziza Karol 2012-06-07 00:42:15 EDT
Created attachment 590063 [details]
msg
Comment 13 errata-xmlrpc 2012-07-10 03:22:34 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1063.html
Comment 14 Steve Linabery 2012-10-29 10:55:28 EDT
*** Bug 798510 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.