Bug 806850 - window xp and 2003 guest with preallocated disk can not boot when import to FC and ISCSI storage after converted using virt-v2v
window xp and 2003 guest with preallocated disk can not boot when import to F...
Status: CLOSED DEFERRED
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-v2v (Show other bugs)
6.3
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Matthew Booth
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-26 07:00 EDT by tingting zheng
Modified: 2014-11-18 06:22 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-11-18 06:22:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of the boot (88.00 KB, image/png)
2012-03-26 07:01 EDT, tingting zheng
no flags Details
OVF file of guest in export domain (4.54 KB, application/xml)
2012-03-26 07:02 EDT, tingting zheng
no flags Details
OVF file of guest in ISCSI storage (4.19 KB, application/xml)
2012-03-26 07:03 EDT, tingting zheng
no flags Details

  None (edit)
Description tingting zheng 2012-03-26 07:00:22 EDT
Description of Problem:
Window xp and 2003 guest with preallocated disk can not boot when import to FC and ISCSI storage after converted using virt-v2v

Version-Release number of selected component (if applicable):
virt-v2v-0.8.7-4.el6.x86_64
libvirt-0.9.10-6.el6.x86_64
llibguestfs-1.16.10-1.el6.x86_64
rhevm:ic155.1
rhev-h:rhev-hypervisor6-6.2-20120320.0.el6_2

How reproducible:
always

Steps to Reproduce:
1.Prepare a xen hvm window 2003 guest with preallocated/raw disk.

2.Use virt-v2v to convert a guest to rhevm.
# virt-v2v  -ic xen+ssh://10.66.72.123 -o rhev -os 10.66.90.115:/vol/v2v_auto/auto_export -n rhevm xen-hvm-win2003-i386
xen-hvm-win2003-i386-2.img: 100% [=====================================================================]D 0h02m15s
virt-v2v: xen-hvm-win2003-i386 configured with virtio drivers.

3.Import the guest to FC and ISCSI storage.

4.Boot the guest,it hangs,details see the screenshot.

5.Shutdown the guest,check the vdsm log,the error messages printed:
Thread-18::ERROR::2012-03-26 09:58:59,097::guestIF::246::vm.Vm::(run) vmId=`afafc5b9-b0ee-4aee-8492-6b59d09ba23c`::Run exception: None
Traceback (most recent call last):
  File "/usr/share/vdsm/guestIF.py", line 238, in run
  File "/usr/share/vdsm/guestIF.py", line 214, in _readLine
  File "/usr/share/vdsm/guestIF.py", line 200, in _readBuffer
error: [Errno 104] Connection reset by peer


Actual results:
When boot the guest in FC and ISCSI storage,it will hang.

Expected results:
The guest should boot successfully in FC and ISCSI storage.
 
Additional info:
1.The guest can boot successfully in NFS storage,Other windows guest like win7 with preallocated/raw disk can boot in FC and ISCSI.

2.Reinstall the guest can not resolve this issue,while reinstall guest with sparse disk,it can boot successfully.

3.When use parameter -oa and -of to designate the type of disk,then the guest can boot successfully.
# virt-v2v  -ic xen+ssh://10.66.72.123 -o rhev -os 10.66.90.115:/vol/v2v_auto/auto_export -n rhevm xen-hvm-win2003-i386 -of qcow2 -oa sparse -on xen-hvm-win2003-i386-test
xen-hvm-win2003-i386-2.img: 100% [=====================================================================]D 0h05m04s
virt-v2v: xen-hvm-win2003-i386-test configured with virtio drivers.

4.The ovf file in export domain and iscsi storage are attached.

5.Until now,I met the issue with guests:xen-hvm-winxp-i386,xen-hvm-win2003-i386,kvm-win2003-i386.
Comment 1 tingting zheng 2012-03-26 07:01:15 EDT
Created attachment 572735 [details]
screenshot of the boot
Comment 3 tingting zheng 2012-03-26 07:02:18 EDT
Created attachment 572736 [details]
OVF file of guest in export domain
Comment 4 tingting zheng 2012-03-26 07:03:12 EDT
Created attachment 572738 [details]
OVF file of guest in ISCSI storage
Comment 5 RHEL Product and Program Management 2012-05-03 00:49:07 EDT
Since RHEL 6.3 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 6 Richard W.M. Jones 2014-11-18 06:22:00 EST
Virt-v2v needs to run on the latest Red Hat Enterprise Linux release
to ensure it can correctly read and modify new guest filesystem
features.  A new version of virt-v2v is now available for RHEL 7.1.

Before RHEL 7.1 is released, follow the instructions here to
install unsupported preview packages on top of RHEL 7.0:
https://www.redhat.com/archives/libguestfs/2014-May/msg00090.html

After RHEL 7.1 is released, virt-v2v will be available in
Technical Preview.

You can run virt-v2v in a single virtual machine.  Other
requirements are covered here:
http://libguestfs.org/virt-v2v.1.html#resource-requirements

If you find a missing feature or bug in the new version of virt-v2v
please file a bug using the following link:
https://bugzilla.redhat.com/enter_bug.cgi?product=Red%20Hat%20Enterprise%20Linux%207&component=libguestfs

Note You need to log in before you can comment on or make changes to this bug.