Bug 806884 - RPM2 can't be built with new rpm-4.10
RPM2 can't be built with new rpm-4.10
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: perl-RPM2 (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Marcela Mašláňová
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-26 08:34 EDT by Marcela Mašláňová
Modified: 2012-04-26 06:00 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-26 06:00:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to hide unpulished names (1.05 KB, patch)
2012-03-30 15:55 EDT, Anton Guda
no flags Details | Diff

  None (edit)
Description Marcela Mašláňová 2012-03-26 08:34:49 EDT
gcc -I/usr/lib64/perl5/CORE -DXS_VERSION="1.0" -DVERSION="1.0" -fPIC -DRPM2_API=4009 -c -D_REENTRANT -D_GNU_SOURCE -fno-strict-aliasing -pipe -fstack-protector -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic -o lib/RPM2.o lib/RPM2.c
lib/RPM2.xs: In function '_null_callback':
lib/RPM2.xs:74:3: error: 'rpmcliHashesCurrent' undeclared (first use in this function)
lib/RPM2.xs:74:3: note: each undeclared identifier is reported only once for each function it appears in
lib/RPM2.xs:85:3: error: 'rpmcliProgressTotal' undeclared (first use in this function)
lib/RPM2.xs:86:3: error: 'rpmcliProgressCurrent' undeclared (first use in this function)
lib/RPM2.xs:90:25: error: 'rpmcliPackagesTotal' undeclared (first use in this function)
lib/RPM2.xs:36:6: warning: variable 'xx' set but not used [-Wunused-but-set-variable]
lib/RPM2.c: In function 'XS_RPM2__C__PackageIterator__iterator_next':
lib/RPM2.c:621:9: warning: variable 'RETVAL' set but not used [-Wunused-but-set-variable]
error building lib/RPM2.o from 'lib/RPM2.c' at /usr/share/perl5/ExtUtils/CBuilder/Base.pm line 175.
error: Bad exit status from /var/tmp/rpm-tmp.okPYIr (%build)
RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.okPYIr (%build)
Comment 1 Anton Guda 2012-03-30 15:55:55 EDT
Created attachment 574087 [details]
Patch to hide unpulished names

Some actions will now work, but core ctill works.
Comment 2 Marcela Mašláňová 2012-04-26 05:26:37 EDT
I didn't catch the maintainer, so I'll push your patch for the meantime. I guess it will need rewrite because many functions are just switched off. Some functions were moved into private parts of rpm.

Note You need to log in before you can comment on or make changes to this bug.