Bug 806886 - [ovirt] [engine-core] force remove pool using wrong query and doesn't remove templates attached
[ovirt] [engine-core] force remove pool using wrong query and doesn't remove ...
Status: CLOSED DUPLICATE of bug 818091
Product: oVirt
Classification: Community
Component: ovirt-engine-core (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity high
: ---
: 3.3.4
Assigned To: mkublin
storage
:
Depends On:
Blocks: 818091
  Show dependency treegraph
 
Reported: 2012-03-26 08:42 EDT by Haim
Modified: 2016-02-10 12:09 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 818091 (view as bug list)
Environment:
Last Closed: 2012-06-10 09:15:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine log. (62.13 KB, application/x-gzip)
2012-03-26 08:42 EDT, Haim
no flags Details

  None (edit)
Description Haim 2012-03-26 08:42:57 EDT
Created attachment 572748 [details]
engine log.

Description of problem:

- pool with 1 domain
- 2 templates
- host
- domain is in problematic state 

Force remove data-base: templates remain, all other objects are deleted 

try remove cluster: 2012-03-26 13:46:09,838 WARN  [org.ovirt.engine.core.bll.RemoveVdsGroupCommand] (http--0.0.0.0-8080-2) CanDoAction of action RemoveVdsGroup failed. Reasons:VAR__TYPE__CLUSTER,VAR__ACTION__REMOVE,VMT_CANNOT_REMOVE_VDS_GROUP_VMTS_DETECTED
,VDS_GROUP_CANNOT_REMOVE_HAS_VM_POOLS
Comment 1 Dafna Ron 2012-05-01 04:45:34 EDT
destroy of domain will also not remove the templates under the domain. 
we can however remove them manually after the destroy.
Comment 2 mkublin 2012-06-10 09:15:17 EDT
I don't understand why bug was closed, so closing my as duplicate

*** This bug has been marked as a duplicate of bug 818091 ***

Note You need to log in before you can comment on or make changes to this bug.