Bug 806890 - mount command outputs the replace-brick started glusterfs process
mount command outputs the replace-brick started glusterfs process
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: krishnan parthasarathi
:
: 807650 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-26 08:50 EDT by Shwetha Panduranga
Modified: 2015-11-03 18:04 EST (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-24 13:16:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shwetha Panduranga 2012-03-26 08:50:29 EDT
Description of problem
when replace-brick is performed, a glusterfs client process is started to migrate the data. executing "mount" command is displaying the replace-brick started glusterfs process also. 

This client process should not be displayed in the mount output as it is internal process started by replace-brick.  

Version-Release number of selected component (if applicable):
mainline

How reproducible:
often

Steps to Reproduce:
1.create a volume. start volume
2.perform replace-brick <old_brick> <new_brick>
3.execute "mount" command on the storage node where replace-brick is started. 
  
Actual results:
[03/26/12 - 22:39:18 root@APP-SERVER1 dstore1]# mount
/dev/sda3 on / type ext4 (rw)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
tmpfs on /dev/shm type tmpfs (rw)
/dev/sda1 on /boot type ext3 (rw)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
sunrpc on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw)
/dev/sdb1 on /export1 type ext4 (rw)
/dev/sdc1 on /export2 type xfs (rw)
/etc/glusterd/vols/dstore/rb_client.vol on /etc/glusterd/vols/dstore/rb_mount type fuse.glusterfs (rw,default_permissions,allow_other,max_read=131072)
Comment 1 krishnan parthasarathi 2012-07-11 03:13:49 EDT
*** Bug 807650 has been marked as a duplicate of this bug. ***
Comment 2 Vijay Bellur 2012-07-30 14:40:17 EDT
CHANGE: http://review.gluster.com/3143 (glusterd: Modifed replace-brick mount cleanup to use lazy umount) merged in master by Anand Avati (avati@redhat.com)

Note You need to log in before you can comment on or make changes to this bug.