Bug 806901 - A rare condition can lead to fail to recv
A rare condition can lead to fail to recv
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: openais (Show other bugs)
5.9
All Linux
urgent Severity urgent
: rc
: ---
Assigned To: Jan Friesse
Cluster QE
: ZStream
Depends On: 758209
Blocks: 791234 791235 791236 812300 812302
  Show dependency treegraph
 
Reported: 2012-03-26 09:11 EDT by Steven Dake
Modified: 2016-04-26 11:44 EDT (History)
4 users (show)

See Also:
Fixed In Version: openais-0.80.6-37.el5
Doc Type: Bug Fix
Doc Text:
Previously, the range condition for the update_aru() function could cause incorrect check of message IDs. Due to this, in rare cases, the corosync utility entered the "FAILED TO RECEIVE" state, and so failed to receive multicast packets. With this update, the range value in the update_aru() function is no longer checked for; the fail_to_recv_const constant performs such checks. Now, corosync does not fail to receive packets.
Story Points: ---
Clone Of: 758209
Environment:
Last Closed: 2013-01-08 02:03:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Backported patch from flatiron (2.33 KB, patch)
2012-04-05 08:18 EDT, Jan Friesse
no flags Details | Diff

  None (edit)
Comment 1 Steven Dake 2012-03-26 09:12:23 EDT
need to fix in 5.9 and z stream.
Comment 2 RHEL Product and Program Management 2012-04-02 06:50:01 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 3 Jan Friesse 2012-04-05 08:18:38 EDT
Created attachment 575385 [details]
Backported patch from flatiron
Comment 9 Jan Friesse 2012-04-24 03:30:47 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Previously, the range condition for the update_aru() function could cause incorrect check of message IDs. Due to this, in rare cases, the corosync utility entered the "FAILED TO RECEIVE" state, and so failed to receive multicast packets. With this update, the range value in the update_aru() function is no longer checked for; the fail_to_recv_const constant performs such checks. Now, corosync does not fail to receive packets.
Comment 12 errata-xmlrpc 2013-01-08 02:03:30 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0013.html

Note You need to log in before you can comment on or make changes to this bug.