Bug 806941 - gtklib-WARNING displayed on CLI when SLA dialog is loaded
gtklib-WARNING displayed on CLI when SLA dialog is loaded
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Michael Stead
Entitlement Bugs
:
Depends On:
Blocks: 738066
  Show dependency treegraph
 
Reported: 2012-03-26 10:46 EDT by Michael Stead
Modified: 2012-06-20 09:08 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 09:08:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Stead 2012-03-26 10:46:55 EDT
Description of problem:

When the SLA dialogs, or message boxes are loaded, libglade-WARNINGS are displayed in the console.


Version-Release number of selected component (if applicable):
[mstead@boogady subscription-manager]$ rpm -qa | grep subscription-manager
subscription-manager-firstboot-0.99.12-1.git.0.aad7061.fc15.x86_64
subscription-manager-migration-0.99.12-1.git.0.aad7061.fc15.x86_64
subscription-manager-0.99.12-1.git.0.aad7061.fc15.x86_64
subscription-manager-gnome-0.99.12-1.git.0.aad7061.fc15.x86_64
subscription-manager-debuginfo-0.99.12-1.git.0.aad7061.fc15.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Ensure system has at least one installed product before registering. I used 37067.pem
2. navigate the registration screens until the service-level selection dialog appears
  
Actual results:

Warnings are shown in the cli.


[mstead@boogady subscription-manager]$ sudo subscription-manager-gui 

(subscription-manager-gui:8341): libglade-WARNING **: unknown attribute `swapped' for <signal>.

(subscription-manager-gui:8341): libglade-WARNING **: unknown attribute `swapped' for <signal>.

(subscription-manager-gui:8341): libglade-WARNING **: unknown attribute `swapped' for <signal>.

Expected results:
No warnings are displayed.
Comment 1 Michael Stead 2012-03-28 12:27:19 EDT
Fixed in master branch: f25ad8f5e4e15f672b7c09e7eaff6cc61d986043

Available in subscription-manager-0.99.13-1+
Comment 3 Shwetha Kallesh 2012-04-05 06:40:23 EDT
moving to verified as the warning is no longer getting dispalyed.

verifying version:

[root@dhcp201-196 ~]# rpm -qa  |grep subscription-manager
subscription-manager-gnome-0.99.12-1.git.13.5a664a0.el6.x86_64
subscription-manager-firstboot-0.99.12-1.git.13.5a664a0.el6.x86_64
subscription-manager-migration-data-1.12.1.2-1.git.0.9e244c8.el6.noarch
subscription-manager-migration-0.99.12-1.git.13.5a664a0.el6.x86_64
subscription-manager-0.99.12-1.git.13.5a664a0.el6.x86_64
Comment 5 errata-xmlrpc 2012-06-20 09:08:16 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0804.html

Note You need to log in before you can comment on or make changes to this bug.