Bug 806982 - xmllint crashes on xpath containing '/../'
xmllint crashes on xpath containing '/../'
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: libxml2 (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Daniel Veillard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-26 13:05 EDT by Daniel Berrange
Modified: 2012-03-27 02:46 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-27 02:46:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Berrange 2012-03-26 13:05:31 EDT
Description of problem:

$ xmllint  --xpath '/../foo' -
<foo/>
Segmentation fault

I'd expect an error message of some kind instead of a crash

Version-Release number of selected component (if applicable):
libxml2-2.7.8-6.fc16.x86_64

How reproducible:
Always
Comment 1 Daniel Veillard 2012-03-27 02:46:01 EDT
Gahh, fixed upstream, the problem was limited to xmllint though :-)

http://git.gnome.org/browse/libxml2/commit/?id=bdc64d6d5f5f30982279af23cfa2d3ab08ba34c4


paphio:~/XML -> xmllint --xpath '/../foo' tst.xml
XPath set is empty
paphio:~/XML -> echo $?
10
paphio:~/XML -> 

One more reason to make that upstream release I have been promising for months !

Daniel

Note You need to log in before you can comment on or make changes to this bug.