Bug 806985 - After adding new Zone, current page is inconvenient
After adding new Zone, current page is inconvenient
Status: CLOSED DUPLICATE of bug 803481
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.0.0
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Angus Thomas
wes hayutin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-26 13:13 EDT by Steve Reichard
Modified: 2012-08-06 19:04 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-06 19:04:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
movie (3.54 MB, video/ogg)
2012-03-26 13:13 EDT, Steve Reichard
no flags Details

  None (edit)
Description Steve Reichard 2012-03-26 13:13:51 EDT
Created attachment 572815 [details]
movie

Description of problem:

I was adding Clouds, their zones, and their catalogs.

When adding a zone, I am in Admin | Cloud and I press the "New Cloud Resource Button".  After adding the zone I am in the Monitor top level.  If I am going to add more zone I need to switch back to Admin | Clouds.   If I am going to add a catalog I need to switch toe Admin | Content | Catalog.   

Leaving me in Monitor is not useful since a zone with out a catalog is not of use.

See attached video

Version-Release number of selected component (if applicable):

early beta6


Red Hat Enterprise Linux Server release 6.2 (Santiago)
Linux cf-cloudforms9.cloud.lab.eng.bos.redhat.com 2.6.32-220.7.1.el6.x86_64 #1 SMP Fri Feb 10 15:22:22 EST 2012 x86_64 x86_64 x86_64 GNU/Linux
postgresql-8.4.9-1.el6_1.1.x86_64
mongodb-1.8.2-3.el6.x86_64
euca2ools-1.3.1-4.el6_0.noarch
ruby-1.8.7.352-6.el6.x86_64
rubygems-1.8.16-1.el6.noarch
deltacloud-core-0.5.0-7.el6.noarch
rubygem-deltacloud-client-0.5.0-2.el6.noarch
package libdeltacloud is not installed
hail-0.8-0.3.gf9c5b967.el6.x86_64
puppet-2.6.14-1.el6.noarch
aeolus-configure-2.5.2-1.el6.noarch
iwhd-1.5-2.el6.x86_64
imagefactory-1.0.0rc10-1.el6.noarch
aeolus-conductor-daemons-0.8.3-1.el6.noarch
aeolus-conductor-0.8.3-1.el6.noarch


How reproducible:

easily

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Scott Seago 2012-03-26 13:31:47 EDT
Yeah, this is a bit clumsy.

The root cause of this is that we've decided that zones/pools belong to the first top-level nav category ("Monitor"), while the parent type of cloud/environment belongs to the second top-level nav category ("Administer").

The related question (which has come up in several contexts) is a more general one -- when you're creating something (a pool, an instance, etc), should you be redirected to the details of the new thing upon creation (so you can configure, etc), or should you be directed to the index view which shows that new thing in the list. The former makes the most sense if you need to configure the thing you just created (and if you could add a new catalog from the zone/pool details itself, this is where you'd want to be anyway). The latter makes more sense if you will be creating several things, one after another, and you don't need to interact with them after creation.

When we don't know which use case will be desired, it's usually safer to go to the details page of the object, since with a sane nav structure you're one click away from the "parent" object (cloud, provider, whatever) -- right now this isn't the case due to the monitor/administer split. On the other hand, if you assume the user wants the index page, if there are more than a small number of items in the list, it's more difficult to "find the thing I just created" to navigate into it to configure.

We'll be revising the overall nav structure post-1.0, so I don't think we'll make any major changes outside of that context, but when we do that I'd propose the following:
1) cloud/environment and pool/zone belong to the same top level nav item, with obvious links from the zone details to the containing cloud page (including zone list)
2) enable catalog creation from the 'catalogs' tab from the zone/pool details view
Comment 2 wes hayutin 2012-03-26 13:34:39 EDT
moving to 1.0.z
Comment 4 Dave Johnson 2012-08-06 19:04:28 EDT

*** This bug has been marked as a duplicate of bug 803481 ***

Note You need to log in before you can comment on or make changes to this bug.