Bug 807004 - SELinux is preventing /usr/bin/totem-video-thumbnailer from 'read' accesses on the file Ot_zakata_do_rassveta_3_[torrents.ru].avi.
SELinux is preventing /usr/bin/totem-video-thumbnailer from 'read' accesses o...
Status: CLOSED DUPLICATE of bug 807005
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:2bf8e56bc06ef3dc630762ce7d4...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-26 14:15 EDT by Mikhail
Modified: 2012-03-27 02:58 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-27 02:58:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mikhail 2012-03-26 14:15:12 EDT
libreport version: 2.0.8
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.3.0-1.fc17.i686.PAE
reason:         SELinux is preventing /usr/bin/totem-video-thumbnailer from 'read' accesses on the file Ot_zakata_do_rassveta_3_[torrents.ru].avi.
time:           Tue 27 Mar 2012 12:15:02 AM YEKT

description:
:SELinux is preventing /usr/bin/totem-video-thumbnailer from 'read' accesses on the file Ot_zakata_do_rassveta_3_[torrents.ru].avi.
:
:*****  Plugin file (36.8 confidence) suggests  *******************************
:
:If you think this is caused by a badly mislabeled machine.
:Then you need to fully relabel.
:Do
:touch /.autorelabel; reboot
:
:*****  Plugin file (36.8 confidence) suggests  *******************************
:
:If you think this is caused by a badly mislabeled machine.
:Then you need to fully relabel.
:Do
:touch /.autorelabel; reboot
:
:*****  Plugin catchall_labels (23.2 confidence) suggests  ********************
:
:If you want to allow totem-video-thumbnailer to have read access on the Ot_zakata_do_rassveta_3_[torrents.ru].avi file
:Then you need to change the label on Ot_zakata_do_rassveta_3_[torrents.ru].avi
:Do
:# semanage fcontext -a -t FILE_TYPE 'Ot_zakata_do_rassveta_3_[torrents.ru].avi'
:where FILE_TYPE is one of the following: user_home_type, sysctl_crypto_t, net_conf_t, cert_t, etc_t, user_tmp_type, gstreamer_home_t, sssd_public_t, abrt_t, lib_t, ld_so_t, xdm_home_t, cpu_online_t, afs_cache_t, abrt_helper_exec_t, thumb_tmp_t, krb5_conf_t, passwd_file_t, bin_t, locale_t, dosfs_t, etc_t, fonts_t, proc_t, thumb_t, sysfs_t, usr_t, textrel_shlib_t, rpm_script_tmp_t, audio_home_t, fonts_cache_t, ld_so_cache_t, samba_var_t, thumb_exec_t, thumb_home_t, shell_exec_t, net_conf_t, abrt_var_run_t, data_home_t, user_cron_spool_t. 
:Then execute: 
:restorecon -v 'Ot_zakata_do_rassveta_3_[torrents.ru].avi'
:
:
:*****  Plugin catchall (5.04 confidence) suggests  ***************************
:
:If you believe that totem-video-thumbnailer should be allowed read access on the Ot_zakata_do_rassveta_3_[torrents.ru].avi file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep totem-video-thu /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023
:Target Context                system_u:object_r:file_t:s0
:Target Objects                Ot_zakata_do_rassveta_3_[torrents.ru].avi [ file ]
:Source                        totem-video-thu
:Source Path                   /usr/bin/totem-video-thumbnailer
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           totem-3.3.92-1.fc17.i686
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-106.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.0-1.fc17.i686.PAE #1 SMP Mon Mar 19
:                              03:11:34 UTC 2012 i686 i686
:Alert Count                   2
:First Seen                    Tue 27 Mar 2012 12:12:48 AM YEKT
:Last Seen                     Tue 27 Mar 2012 12:13:19 AM YEKT
:Local ID                      c58c4d46-be0e-41db-bfa1-f3a7e32c4472
:
:Raw Audit Messages
:type=AVC msg=audit(1332785599.43:185): avc:  denied  { read } for  pid=4462 comm="totem-video-thu" name="Ot_zakata_do_rassveta_3_[torrents.ru].avi" dev="sdb1" ino=27920859 scontext=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 tcontext=system_u:object_r:file_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1332785599.43:185): arch=i386 syscall=open success=no exit=EACCES a0=96a79b8 a1=8000 a2=0 a3=0 items=0 ppid=2521 pid=4462 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 tty=(none) ses=4 comm=totem-video-thu exe=/usr/bin/totem-video-thumbnailer subj=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 key=(null)
:
:Hash: totem-video-thu,thumb_t,file_t,file,read
:
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:
:
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
:
:
Comment 1 Miroslav Grepl 2012-03-27 02:58:56 EDT

*** This bug has been marked as a duplicate of bug 807005 ***

Note You need to log in before you can comment on or make changes to this bug.