Bug 807022 - [ALL LANG] Translation needed for string "Product ID:"
[ALL LANG] Translation needed for string "Product ID:"
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Bryan Kearney
Entitlement Bugs
: i18n, Translation
Depends On:
Blocks: 738066
  Show dependency treegraph
 
Reported: 2012-03-26 15:16 EDT by John Sefler
Modified: 2012-06-20 09:08 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 09:08:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Missing translation for "Product ID:" (83.28 KB, image/png)
2012-03-26 15:16 EDT, John Sefler
no flags Details

  None (edit)
Description John Sefler 2012-03-26 15:16:33 EDT
Created attachment 572853 [details]
Missing translation for "Product ID:"

Description of problem:
The string "Product ID:" has not yet been extracted for translation in the subscription-manager-gui.   See attached screenshot.


Version-Release number of selected component (if applicable):
[root@jsefler-r63-server ~]# rpm -q subscription-manager
subscription-manager-0.99.12-1.git.1.2b349d3.el6.x86_64


How reproducible:


Steps to Reproduce:
[root@jsefler-r63-server ~]# msgunfmt /usr/share/locale/ja/LC_MESSAGES/rhsm.mo | grep -i "Product ID"
msgid "Product Id:           \t%-25s"
[root@jsefler-r63-server ~]# 


^^ Expected grep to find a hit on "Product ID:"
Comment 4 John Sefler 2012-04-13 17:08:15 EDT
[root@jsefler-r63-server ~]# rpm -q subscription-manager
subscription-manager-0.99.14-1.el6.x86_64



[root@jsefler-r63-server ~]# for L in de es fr it ja ko pt ru zh_CN as bn hi mr gu kn ml or pa ta te; do echo ""; echo "LOOKING FOR 'Product ID' TRANSLATION IN LANG $L.............."; msgunfmt /usr/share/locale/$L/LC_MESSAGES/rhsm.mo | grep -i 'Product ID:' -A1; done;

LOOKING FOR 'Product ID' TRANSLATION IN LANG de..............
msgid "<b>Product ID:</b>"
msgstr "<b>Produkt-ID:</b>"
--
msgid "Product ID:           \t%-25s"
msgstr "Produkt-ID:           \t%-25s"
--
msgid "Product Id:           \t%-25s"
msgstr "Produkt-ID:           \t%-25s"

LOOKING FOR 'Product ID' TRANSLATION IN LANG es..............
msgid "<b>Product ID:</b>"
msgstr "<b>ID del producto:</b>"
--
msgid "Product ID:           \t%-25s"
msgstr "ID del producto: %-25s"
--
msgid "Product Id:           \t%-25s"
msgstr "ID de producto: %-25s"

LOOKING FOR 'Product ID' TRANSLATION IN LANG fr..............
msgid "Product Id:           \t%-25s"
msgstr "ID du produit : %-25s"

LOOKING FOR 'Product ID' TRANSLATION IN LANG it..............
msgid "<b>Product ID:</b>"
msgstr "<b>ID del prodotto:</b>"
--
msgid "Product ID:           \t%-25s"
msgstr "ID prodotto:           \t%-25s"
--
msgid "Product Id:           \t%-25s"
msgstr "Id prodotto: %-25s"

LOOKING FOR 'Product ID' TRANSLATION IN LANG ja..............
msgid "<b>Product ID:</b>"
msgstr "<b>製品 ID:</b>"
--
msgid "Product ID:           \t%-25s"
msgstr "製品 ID:  %-25s"
--
msgid "Product Id:           \t%-25s"
msgstr "製品 Id: %-25s"

LOOKING FOR 'Product ID' TRANSLATION IN LANG ko..............
msgid "<b>Product ID:</b>"
msgstr "<b>제품 ID:</b>"
--
msgid "Product ID:           \t%-25s"
msgstr "제품 ID: %-25s"
--
msgid "Product Id:           \t%-25s"
msgstr "제품 ID: %-25s"

LOOKING FOR 'Product ID' TRANSLATION IN LANG pt..............
msgid "<b>Product ID:</b>"
msgstr "<b>Product ID:</b>"

--
msgid "Product ID:           \t%-25s"
msgstr "Product ID:           \t%-25s"

msgid "Product Id:           \t%-25s"
msgstr "Id do Produto:           \t%-25s"

LOOKING FOR 'Product ID' TRANSLATION IN LANG ru..............
msgid "Product Id:           \t%-25s"
msgstr "ID продукта: %-25s"

LOOKING FOR 'Product ID' TRANSLATION IN LANG zh_CN..............
msgid "<b>Product ID:</b>"
msgstr "<b>产品 ID:</b>"
--
msgid "Product ID:           \t%-25s"
msgstr "产品 ID:%-25s"
--
msgid "Product Id:           \t%-25s"
msgstr "产品 ID:%-25s"

LOOKING FOR 'Product ID' TRANSLATION IN LANG as..............
msgid "<b>Product ID:</b>"
msgstr "<b>উৎপাদন ID:</b>"
--
msgid "Product ID:           \t%-25s"
msgstr "উৎপাদন ID:           \t%-25s"
--
msgid "Product Id:           \t%-25s"
msgstr "উৎপাদন আইডি: %-25s"

LOOKING FOR 'Product ID' TRANSLATION IN LANG bn..............
msgid "Product Id:           \t%-25s"
msgstr "উৎপাদনের Id:           \t%-25s"

LOOKING FOR 'Product ID' TRANSLATION IN LANG hi..............
msgid "<b>Product ID:</b>"
msgstr "<b>उत्पाद ID:</b>"
--
msgid "Product ID:           \t%-25s"
msgstr "उत्पाद ID:           \t%-25s"
--
msgid "Product Id:           \t%-25s"
msgstr "उत्पाद आईडी:%-25s"

LOOKING FOR 'Product ID' TRANSLATION IN LANG mr..............
msgid "<b>Product ID:</b>"
msgstr "<b>उत्पादन ID:</b>"
--
msgid "Product ID:           \t%-25s"
msgstr "उत्पादन ID:           \t%-25s"
--
msgid "Product Id:           \t%-25s"
msgstr "उत्पादन Id:           \t%-25s"

LOOKING FOR 'Product ID' TRANSLATION IN LANG gu..............
msgid "<b>Product ID:</b>"
msgstr "<b>પ્રોડક્ટ ID:</b>"
--
msgid "Product ID:           \t%-25s"
msgstr "પ્રોડક્ટ ID:           \t%-25s"
--
msgid "Product Id:           \t%-25s"
msgstr "પ્રોડક્ટ Id: %-25s"

LOOKING FOR 'Product ID' TRANSLATION IN LANG kn..............
msgid "Product Id:           \t%-25s"
msgstr "ಉತ್ಪನ್ನ Id: %-25s"

LOOKING FOR 'Product ID' TRANSLATION IN LANG ml..............
msgid "<b>Product ID:</b>"
msgstr "<b>പ്രൊഡക്ട് ഐഡി:</b>"
--
msgid "Product ID:           \t%-25s"
msgstr "പ്രൊഡക്ടിന്റെ ഐഡി: %-25s"
--
msgid "Product Id:           \t%-25s"
msgstr "പ്രൊഡക്ട് ഐഡി: %-25s"

LOOKING FOR 'Product ID' TRANSLATION IN LANG or..............
msgid "<b>Product ID:</b>"
msgstr "<b>ଉତ୍ପାଦନ ID:</b>"
--
msgid "Product ID:           \t%-25s"
msgstr "ଉତ୍ପାଦନ ID: %-25s"
--
msgid "Product Id:           \t%-25s"
msgstr "ଉତ୍ପାଦନ Id: %-25s"

LOOKING FOR 'Product ID' TRANSLATION IN LANG pa..............
msgid "<b>Product ID:</b>"
msgstr "<b>ਉਤਪਾਦ ID:</b>"
--
msgid "Product ID:           \t%-25s"
msgstr "ਉਤਪਾਦ ID:           \t%-25s"
--
msgid "Product Id:           \t%-25s"
msgstr "ਉਤਪਾਦ Id:           \t%-25s"

LOOKING FOR 'Product ID' TRANSLATION IN LANG ta..............
msgid "Product Id:           \t%-25s"
msgstr "தயாரிப்பு Id:           \t%-25s"

LOOKING FOR 'Product ID' TRANSLATION IN LANG te..............
msgid "<b>Product ID:</b>"
msgstr "<b>ఉత్పత్తి ఐడి:</b>"
--
msgid "Product ID:           \t%-25s"
msgstr "ఉత్పత్తి ID:           \t%-25s"
--
msgid "Product Id:           \t%-25s"
msgstr "ఉత్పత్తి ఐడి:           \t%-25s"
[root@jsefler-r63-server ~]# 


^^^ VERIFIED, The string "Product ID:" has now been extracted and translated.

Moving this bug to VERIFIED...

However, some translations are incomplete.  Opening separate Bug 812483 - [fr_FR] [ru_RU] [bn_IN] [kn_IN] [ta_IN] "Product ID:" is not translated.
Comment 6 errata-xmlrpc 2012-06-20 09:08:18 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0804.html

Note You need to log in before you can comment on or make changes to this bug.