Bug 807026 - SELinux is preventing /usr/libexec/polkit-1/polkit-agent-helper-1 from read, append access on the file /home/luis/.xsession-errors.
SELinux is preventing /usr/libexec/polkit-1/polkit-agent-helper-1 from read, ...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
16
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:68466e3ab6ff5ecf70cc50d34ce...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-26 15:28 EDT by Luis Lugo
Modified: 2012-03-27 08:03 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-27 08:03:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Luis Lugo 2012-03-26 15:28:47 EDT
libreport version: 2.0.8
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.3.0-4.fc16.i686.PAE
reason:         SELinux is preventing /usr/libexec/polkit-1/polkit-agent-helper-1 from read, append access on the file /home/luis/.xsession-errors.
time:           Mon 26 Mar 2012 12:27:56 PM PDT

description:
:SELinux is preventing /usr/libexec/polkit-1/polkit-agent-helper-1 from read, append access on the file /home/luis/.xsession-errors.
:
:*****  Plugin restorecon (98.5 confidence) suggests  *************************
:
:If you want to fix the label. 
:/home/luis/.xsession-errors default label should be xdm_home_t.
:Then you can run restorecon.
:Do
:# /sbin/restorecon -v /home/luis/.xsession-errors
:
:*****  Plugin catchall (1.48 confidence) suggests  ***************************
:
:If you believe that polkit-agent-helper-1 should be allowed read append access on the .xsession-errors file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep polkit-agent-he /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:*****  Plugin leaks (1.48 confidence) suggests  ******************************
:
:If you want to ignore polkit-agent-helper-1 trying to read append access the .xsession-errors file, because you believe it should not need this access.
:Then you should report this as a bug.  
:You can generate a local policy module to dontaudit this access.
:Do
:# grep /usr/libexec/polkit-1/polkit-agent-helper-1 /var/log/audit/audit.log | audit2allow -D -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                unconfined_u:unconfined_r:policykit_auth_t:s0-s0:c
:                              0.c1023
:Target Context                unconfined_u:object_r:user_home_dir_t:s0
:Target Objects                /home/luis/.xsession-errors [ file ]
:Source                        polkit-agent-he
:Source Path                   /usr/libexec/polkit-1/polkit-agent-helper-1
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           polkit-0.102-3.fc16.i686
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-80.fc16.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux llugo13 3.3.0-4.fc16.i686.PAE #1 SMP Tue Mar
:                              20 18:24:16 UTC 2012 i686 i686
:Alert Count                   1
:First Seen                    Sun 25 Mar 2012 10:13:47 PM PDT
:Last Seen                     Sun 25 Mar 2012 10:13:47 PM PDT
:Local ID                      7d14456e-6ab2-4e8d-aff4-1618b8399769
:
:Raw Audit Messages
:type=AVC msg=audit(1332738827.851:533): avc:  denied  { read append } for  pid=18964 comm="polkit-agent-he" path="/home/luis/.xsession-errors" dev="sda4" ino=25165833 scontext=unconfined_u:unconfined_r:policykit_auth_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_home_dir_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1332738827.851:533): arch=i386 syscall=execve success=yes exit=0 a0=4199184c a1=bfb9e77c a2=94a7330 a3=bfb9e77c items=0 ppid=16006 pid=18964 auid=1000 uid=1000 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=24 comm=polkit-agent-he exe=/usr/libexec/polkit-1/polkit-agent-helper-1 subj=unconfined_u:unconfined_r:policykit_auth_t:s0-s0:c0.c1023 key=(null)
:
:Hash: polkit-agent-he,policykit_auth_t,user_home_dir_t,file,read,append
:
:audit2allow
:
:#============= policykit_auth_t ==============
:allow policykit_auth_t user_home_dir_t:file { read append };
:
:audit2allow -R
:
:#============= policykit_auth_t ==============
:allow policykit_auth_t user_home_dir_t:file { read append };
:
Comment 1 Miroslav Grepl 2012-03-27 08:03:50 EDT
Your home directory is mislabeled. Could you execute

$ restorecon -R -v ~/

to fix this issue. Thank you.

Note You need to log in before you can comment on or make changes to this bug.