Bug 807047 - rhn-channel displays a stacktrace instead of an error
rhn-channel displays a stacktrace instead of an error
Status: CLOSED DUPLICATE of bug 781421
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: rhn-client-tools (Show other bugs)
6.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Miroslav Suchý
Red Hat Satellite QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-26 16:45 EDT by Mikulas Patocka
Modified: 2012-03-28 07:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-28 07:31:11 EDT
Type: Bug
Regression: ---
Mount Type: All
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mikulas Patocka 2012-03-26 16:45:47 EDT
Description of problem:
When Czech utf-8 locale is used, rhn-channel displays a python stacktrace instead of an error message.

Version-Release number of selected component (if applicable):
rhn-setup-1.0.0-73.el6.noarch

How reproducible:
always

Steps to Reproduce:
export LANG=cs_CZ.UTF-8
rhn-channel --add -c bla

Actual results:
Username: mpatocka
Password:

Traceback (most recent call last):
  File "/usr/sbin/rhn-channel", line 162, in <module>
    systemExit(1, e)
  File "/usr/sbin/rhn-channel", line 37, in systemExit
    sys.stderr.write(str(msg)+'\n')
UnicodeEncodeError: 'ascii' codec can't encode character u'\u0159' in position 7: ordinal not in range(128)

Expected results:
It shoudn't display the stacktrace.
Comment 2 Miroslav Suchý 2012-03-28 07:31:11 EDT

*** This bug has been marked as a duplicate of bug 781421 ***

Note You need to log in before you can comment on or make changes to this bug.