Bug 807107 - No notification when instance can't be launched because quota is reached
Summary: No notification when instance can't be launched because quota is reached
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: CloudForms Cloud Engine
Classification: Retired
Component: aeolus-conductor
Version: 1.0.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: rc
Assignee: Angus Thomas
QA Contact: wes hayutin
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-03-27 03:52 UTC by james labocki
Modified: 2012-12-04 15:01 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Attempts to launch an application without enough quota in the Cloud Resource Zone disabled the launch button but provided no error message. This update provides users with the appropriate error message.
Clone Of:
Environment:
Last Closed: 2012-12-04 15:01:15 UTC


Attachments (Terms of Use)
launch button greyed, but no explanation for user of why (222.74 KB, image/png)
2012-03-27 03:54 UTC, james labocki
no flags Details
quota_reached (205.44 KB, image/png)
2012-05-03 12:37 UTC, pushpesh sharma
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2012:1516 0 normal SHIPPED_LIVE CloudForms Cloud Engine 1.1 update 2012-12-04 19:51:45 UTC

Description james labocki 2012-03-27 03:52:22 UTC
Description of problem:
No notification is given to the user when instance can't be launched because quota is reached (see screenshot attached).

Version-Release number of selected component (if applicable):
1.0 beta4

How reproducible:
Launch an application that puts you over a quota on a cloud resource zone. You will not be able to select the Launch button, but no reasons are provided to the user.

Expected results:
Provide the user with a message explaining that they are not able to launch because launching the instance would cause them to go over their quota. If possible, provide a link to edit the resource zone if they have permissions to do so, otherwise refer them to the administrator of CloudForms to ask for help.

Comment 1 james labocki 2012-03-27 03:54:21 UTC
Created attachment 572915 [details]
launch button greyed, but no explanation for user of why

Comment 3 pushpesh sharma 2012-05-03 12:36:33 UTC
works for me, see screen shot, error message is displayed

Comment 4 pushpesh sharma 2012-05-03 12:37:10 UTC
Created attachment 581850 [details]
quota_reached

Comment 5 Angus Thomas 2012-06-21 16:24:36 UTC
Hi Pushpesh

Could you please close this BZ< as your comments demonstrate that it is resolved.


Thanks,

Angus

Comment 7 errata-xmlrpc 2012-12-04 15:01:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html


Note You need to log in before you can comment on or make changes to this bug.