Bug 80711 - redhat-config-printer does not setup domain for samba printers
redhat-config-printer does not setup domain for samba printers
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: redhat-config-printer (Show other bugs)
phoebe
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-12-30 05:21 EST by Pavel
Modified: 2007-04-18 12:49 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-09 05:54:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel 2002-12-30 05:21:16 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20021229

Description of problem:
When I add a smb printer , I'm unable to print on it unless I edit the printer
and set a domain name in WORKGROUP field ('Queue type' tab).

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Setup an smb printer
2.
3.
    

Actual Results:  Unable to use the printer until domain name specified

Expected Results:  Ability to specify domain name during initial printer setup
or getting domain name from samba config file

Additional info:
Comment 1 Tim Waugh 2002-12-30 08:00:47 EST
The 'specify' dialog probably should be changed to allow you to set this.

I'm puzzled about why it wasn't set in the first place though; the browse screen
should have worked it out.  When you selected it and added the queue, is
'workgroup' just empty when you edit it?  For me, it sets the workgroup field to
the right value already.
Comment 2 Pavel 2002-12-30 09:08:26 EST
redhat-config-printer is unable to list any printers because it tries to login
as ROOT to windows servers. I have to use 'Specify' button to specyfy printer,
and this dialog does not allow me to enter workgroup/domain name.
Comment 3 Pavel 2002-12-30 09:21:59 EST
BTW, some computer names displayed incorrectly, for example in my network
PROUTER displayed as IS~PROUTER, MOSHEO displayed as IS~MOSHEO.
Comment 4 Tim Waugh 2002-12-30 12:30:15 EST
Okay, the 'specify' dialog is now fixed in CVS, and automatically determines the
workgroup and IP address.

For the incorrectly-shown names, can you please try this, and show me the output?:

1. nmblookup '*'
2. for each IP address that it shows, nmblookup -A 172.16.10.1 (or whatever)

(If you happen to know the IP address of e.g. PROUTER, just nmblookup -A
<ipaddr> should be enough to figure out what's up.)

Thanks.
Comment 5 Tim Waugh 2002-12-30 12:59:25 EST
Incidentally, the 'specify' dialog behaviour fix is in
redhat-config-printer-0.6.27-1, which will shortly appear in rawhide.
Comment 6 Pavel 2002-12-31 03:22:06 EST
Here is an output of 'nmblookup -A 10.0.5.12' (PROUTER):
Looking up status of 10.0.5.12
	PROUTER         <00> -         M <ACTIVE> 
	NCDEV           <00> - <GROUP> M <ACTIVE> 
	PROUTER         <03> -         M <ACTIVE> 
	PROUTER$        <03> -         M <ACTIVE> 
	PROUTER         <20> -         M <ACTIVE> 
	NCDEV           <1e> - <GROUP> M <ACTIVE> 
	INet~Services   <1c> - <GROUP> M <ACTIVE> 
	IS~PROUTER      <00> -         M <ACTIVE> 
 
Comment 7 Tim Waugh 2003-01-03 07:19:55 EST
Okay, I think I've fixed that in CVS.
Comment 8 Tim Waugh 2003-01-03 08:30:42 EST
Fixed package is redhat-config-printer-0.6.28-1, which will shortly appear in
rawhide.  Please verify that it fixes the problem for you.
Comment 9 Pavel 2003-01-08 08:26:45 EST
Still doesn't work for me. Workgroup field is empty for manually specified
printers. Sorry :)
Comment 10 Tim Waugh 2003-01-08 08:52:56 EST
Please do this:

cd /usr/share/printconf/util
python
>>> import pysmb
>>> pysmb.get_host_info ("PROUTER")
(then control-D)

What does it say?
Comment 11 Pavel 2003-01-08 12:38:55 EST
It prints:
{'IP': '', 'GROUP': '', 'NAME': 'PROUTER'}

I researched it a bit more, and I think I understand my problem. For some
reason, my print server does not respond to broadcast queries on the interface
to which my machine is connected and nmblookup '*' can't find it. 
On the other hand if I connect my RHL machine to other network, it finds print
server and configures workgroup properly after I specify share manually.

Is there a better way to get list of servers, like querying a wins server?
Comment 12 Tim Waugh 2003-01-08 12:51:44 EST
I was rather hoping that nmblookup would check for a WINS server in smb.conf if
broadcasting failed, but it seems that it doesn't.

Presumably, 'nmblookup -U your_wins_server -S PROUTER' gives you the workgroup
information?
Comment 13 Pavel 2003-01-08 12:57:34 EST
No, but 
nmblookup -R -U wins_server -S PROUTER 
does the job
Comment 14 Tim Waugh 2003-01-08 13:42:25 EST
Okay, redhat-config-printer-0.6.32-1 is another attempt at getting this right. 
I've put it at ftp://people.redhat.com/twaugh/tmp (just rpmbuild --rebuild it).
 Let me know if it's any better.  Thanks.
Comment 15 Pavel 2003-01-09 05:52:27 EST
Worked for me :). Great. Thanks.
Comment 16 Tim Waugh 2003-01-09 05:54:13 EST
Good.  You don't want to know how it does it though. :-)

Note You need to log in before you can comment on or make changes to this bug.